Plugin Namespace

[image]

NiconamaCommentViwer Plug-in Documents
Plugin Namespace
フィードバックの送信
Plugin名前空間

Classes

 | Class | Description
Public class | AppSettingInPlugin | アプリケーション設定のコピークラス
Public class | AppSettingInPlugin..::..DGVColorSetting | コメント表示色設定
Public class | AppSettingInPlugin..::..LoginUserSetting | ログインユーザー設定
Public class | AppSettingInPlugin..::..ReadingOutSetting | コメント読み上げ設定
Public class | ConfigureOriginalNGWordInPlugin | NG設定
Public class | ConfigureOriginalNGWordInPlugin..::..NGClient | NG設定格納用構造体
Public class | HeartBeatUpdatedEventArgs | HeartBeatUpdatedイベントのデータ
Public class | ReceivedCommentEventArgs | ReceivedCommentイベントのデータ
Public class | SettingDirectoryChangedEventArgs | 設定ファイル保存フォルダ変更イベントのデータ
Public class | UserSettingInPlugin | ユーザー設定
Public class | UserSettingInPlugin..::..UserData | ユーザー設定格納用構造体
Public class | VersionInfo | バージョン情報

Interfaces

 | Interface | Description
Public interface | IPlugin | プラグインで実装するインターフェイス
Public interface | IPluginEx | プラグインで実装するインターフェイス（メインメニューの「設定」項目からプラグイン設定を実行できる）
Public interface | IPluginHost | プラグインのホストで実装するインターフェイス

Delegates

 | Delegate | Description
Public delegate | BroadcastConnectedEventHandler | BroadcastConnectedイベントのデリゲート
Public delegate | BroadcastDisConnectedEventHandler | BroadcastDisConnectedイベントのデリゲート
Public delegate | CommentLogOpenedEventHandler | CommentLogOpenedイベントのデリゲート
Public delegate | HeartBeatUpdatedEventHandler | HeartBeatUpdatedイベントのデリゲート
Public delegate | ReceivedCommentEventHandler | ReceivedCommentイベントのデリゲート
Public delegate | SettingDirectoryChangedEventHandler | 設定ファイル保存フォルダ変更イベントのデリゲート
Public delegate | WaybackCommentReceivedEventHandler | WaybackCommentReceivedイベントのデリゲート

Enumerations

 | Enumeration | Description
Public enumeration | NGShareLevels |
Public enumeration | ReadingOutApp |


AppSettingInPlugin Class

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin Class
Members See Also フィードバックの送信
アプリケーション設定のコピークラス

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class AppSettingInPlugin
Visual Basic
Public Class AppSettingInPlugin
Visual C++
public ref class AppSettingInPlugin

Inheritance Hierarchy

System..::..Object
Plugin..::..AppSettingInPlugin

See Also

AppSettingInPlugin Members
Plugin Namespace


AppSettingInPlugin Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin Members
AppSettingInPlugin Class Constructors Methods Properties See Also フィードバックの送信

The AppSettingInPlugin type exposes the following members.

Constructors

 | Name | Description
Public method | AppSettingInPlugin | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | CommentFont | コメント一覧表示フォント
Public property | DGVColor | コメント一覧表示色
Public property | LoginUser | ログインユーザー設定
Public property | ReadingOut |

See Also

AppSettingInPlugin Class


AppSettingInPlugin Constructor

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin Constructor
AppSettingInPlugin Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public AppSettingInPlugin()
Visual Basic
Public Sub New
Visual C++
public:
AppSettingInPlugin()

See Also

AppSettingInPlugin Class


AppSettingInPlugin Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin Methods
AppSettingInPlugin Class See Also フィードバックの送信

The AppSettingInPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

AppSettingInPlugin Class


AppSettingInPlugin Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin Properties
AppSettingInPlugin Class See Also フィードバックの送信

The AppSettingInPlugin type exposes the following members.

Properties

 | Name | Description
Public property | CommentFont | コメント一覧表示フォント
Public property | DGVColor | コメント一覧表示色
Public property | LoginUser | ログインユーザー設定
Public property | ReadingOut |

See Also

AppSettingInPlugin Class


CommentFont Property

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..CommentFont Property
AppSettingInPlugin Class See Also フィードバックの送信
コメント一覧表示フォント

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string CommentFont { get; set; }
Visual Basic
Public Property CommentFont As String
    Get
    Set
Visual C++
public:
property String^ CommentFont {
    String^ get ();
    void set (String^ value);
}

See Also

AppSettingInPlugin Class


DGVColor Property

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColor Property
AppSettingInPlugin Class See Also フィードバックの送信
コメント一覧表示色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public AppSettingInPlugin..::..DGVColorSetting DGVColor { get; set; }
Visual Basic
Public Property DGVColor As AppSettingInPlugin..::..DGVColorSetting
    Get
    Set
Visual C++
public:
property AppSettingInPlugin..::..DGVColorSetting^ DGVColor {
    AppSettingInPlugin..::..DGVColorSetting^ get ();
    void set (AppSettingInPlugin..::..DGVColorSetting^ value);
}

See Also

AppSettingInPlugin Class


LoginUser Property

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..LoginUser Property
AppSettingInPlugin Class See Also フィードバックの送信
ログインユーザー設定

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public AppSettingInPlugin..::..LoginUserSetting LoginUser { get; set; }
Visual Basic
Public Property LoginUser As AppSettingInPlugin..::..LoginUserSetting
    Get
    Set
Visual C++
public:
property AppSettingInPlugin..::..LoginUserSetting^ LoginUser {
    AppSettingInPlugin..::..LoginUserSetting^ get ();
    void set (AppSettingInPlugin..::..LoginUserSetting^ value);
}

See Also

AppSettingInPlugin Class


ReadingOut Property

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOut Property
AppSettingInPlugin Class See Also フィードバックの送信

[Missing <summary> documentation for "P:Plugin.AppSettingInPlugin.ReadingOut"]

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public AppSettingInPlugin..::..ReadingOutSetting ReadingOut { get; set; }
Visual Basic
Public Property ReadingOut As AppSettingInPlugin..::..ReadingOutSetting
    Get
    Set
Visual C++
public:
property AppSettingInPlugin..::..ReadingOutSetting^ ReadingOut {
    AppSettingInPlugin..::..ReadingOutSetting^ get ();
    void set (AppSettingInPlugin..::..ReadingOutSetting^ value);
}

See Also

AppSettingInPlugin Class


AppSettingInPlugin.DGVColorSetting Class

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting Class
AppSettingInPlugin Class Members See Also フィードバックの送信
コメント表示色設定

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class DGVColorSetting
Visual Basic
Public Class DGVColorSetting
Visual C++
public ref class DGVColorSetting

Inheritance Hierarchy

System..::..Object
Plugin..::..AppSettingInPlugin..::..DGVColorSetting

See Also

AppSettingInPlugin..::..DGVColorSetting Members


AppSettingInPlugin.DGVColorSetting Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting Members
AppSettingInPlugin..::..DGVColorSetting Class Constructors Methods Fields See Also フィードバックの送信

アプリケーション設定のコピークラス

The AppSettingInPlugin..::..DGVColorSetting type exposes the following members.

Constructors

 | Name | Description
Public method | AppSettingInPlugin..::..DGVColorSetting | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Fields

 | Name | Description
Public field | AllRoomNumForeColor | 全部屋同時表示時のコメント番号文字色
Public field | AnonUserIDLinkColor | 184IDリンク色
Public field | Arena_NumBGColor | 全部屋同時表示時のアリーナ部屋コメント番号背景色
Public field | BGColor | 背景色
Public field | CommentColor | コマンド文字色を反映するかどうか
Public field | FirstCommentColor | 取得済みコメントで各ユーザーID最初のコメント文字色
Public field | ForeignCommentColor | 外国からのコメント文字色
Public field | InterlinearGridColor | 行間グリッド色
Public field | NGCommentColor | NGコメント文字色
Public field | NormalForeColor | 基本文字色
Public field | OwnerCommentColor | 運営コメント文字色
Public field | StandingA_NumBGColor | 全部屋同時表示時の立ち見A部屋コメント番号背景色
Public field | StandingB_NumBGColor | 全部屋同時表示時の立ち見B部屋コメント番号背景色
Public field | StandingC_NumBGColor | 全部屋同時表示時の立ち見C部屋コメント番号背景色
Public field | StandingD_NumBGColor | 全部屋同時表示時の立ち見D部屋コメント番号背景色
Public field | StandingE_NumBGColor | 全部屋同時表示時の立ち見E部屋コメント番号背景色
Public field | UserIDLinkColor | 生IDリンク色

See Also

AppSettingInPlugin..::..DGVColorSetting Class


AppSettingInPlugin.DGVColorSetting Constructor

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting Constructor
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public DGVColorSetting()
Visual Basic
Public Sub New
Visual C++
public:
DGVColorSetting()

See Also

AppSettingInPlugin..::..DGVColorSetting Class


AppSettingInPlugin.DGVColorSetting Fields

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting Fields
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信

The AppSettingInPlugin..::..DGVColorSetting type exposes the following members.

Fields

 | Name | Description
Public field | AllRoomNumForeColor | 全部屋同時表示時のコメント番号文字色
Public field | AnonUserIDLinkColor | 184IDリンク色
Public field | Arena_NumBGColor | 全部屋同時表示時のアリーナ部屋コメント番号背景色
Public field | BGColor | 背景色
Public field | CommentColor | コマンド文字色を反映するかどうか
Public field | FirstCommentColor | 取得済みコメントで各ユーザーID最初のコメント文字色
Public field | ForeignCommentColor | 外国からのコメント文字色
Public field | InterlinearGridColor | 行間グリッド色
Public field | NGCommentColor | NGコメント文字色
Public field | NormalForeColor | 基本文字色
Public field | OwnerCommentColor | 運営コメント文字色
Public field | StandingA_NumBGColor | 全部屋同時表示時の立ち見A部屋コメント番号背景色
Public field | StandingB_NumBGColor | 全部屋同時表示時の立ち見B部屋コメント番号背景色
Public field | StandingC_NumBGColor | 全部屋同時表示時の立ち見C部屋コメント番号背景色
Public field | StandingD_NumBGColor | 全部屋同時表示時の立ち見D部屋コメント番号背景色
Public field | StandingE_NumBGColor | 全部屋同時表示時の立ち見E部屋コメント番号背景色
Public field | UserIDLinkColor | 生IDリンク色

See Also

AppSettingInPlugin..::..DGVColorSetting Class


AllRoomNumForeColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..AllRoomNumForeColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
全部屋同時表示時のコメント番号文字色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int AllRoomNumForeColor
Visual Basic
Public AllRoomNumForeColor As Integer
Visual C++
public:
int AllRoomNumForeColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


AnonUserIDLinkColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..AnonUserIDLinkColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
184IDリンク色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int AnonUserIDLinkColor
Visual Basic
Public AnonUserIDLinkColor As Integer
Visual C++
public:
int AnonUserIDLinkColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


Arena_NumBGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..Arena_NumBGColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
全部屋同時表示時のアリーナ部屋コメント番号背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int Arena_NumBGColor
Visual Basic
Public Arena_NumBGColor As Integer
Visual C++
public:
int Arena_NumBGColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


BGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..BGColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int BGColor
Visual Basic
Public BGColor As Integer
Visual C++
public:
int BGColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


CommentColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..CommentColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
コマンド文字色を反映するかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool CommentColor
Visual Basic
Public CommentColor As Boolean
Visual C++
public:
bool CommentColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


FirstCommentColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..FirstCommentColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
取得済みコメントで各ユーザーID最初のコメント文字色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int FirstCommentColor
Visual Basic
Public FirstCommentColor As Integer
Visual C++
public:
int FirstCommentColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


ForeignCommentColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..ForeignCommentColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
外国からのコメント文字色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int ForeignCommentColor
Visual Basic
Public ForeignCommentColor As Integer
Visual C++
public:
int ForeignCommentColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


InterlinearGridColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..InterlinearGridColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
行間グリッド色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int InterlinearGridColor
Visual Basic
Public InterlinearGridColor As Integer
Visual C++
public:
int InterlinearGridColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


NGCommentColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..NGCommentColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
NGコメント文字色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int NGCommentColor
Visual Basic
Public NGCommentColor As Integer
Visual C++
public:
int NGCommentColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


NormalForeColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..NormalForeColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
基本文字色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int NormalForeColor
Visual Basic
Public NormalForeColor As Integer
Visual C++
public:
int NormalForeColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


OwnerCommentColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..OwnerCommentColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
運営コメント文字色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int OwnerCommentColor
Visual Basic
Public OwnerCommentColor As Integer
Visual C++
public:
int OwnerCommentColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


StandingA_NumBGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..StandingA_NumBGColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
全部屋同時表示時の立ち見A部屋コメント番号背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int StandingA_NumBGColor
Visual Basic
Public StandingA_NumBGColor As Integer
Visual C++
public:
int StandingA_NumBGColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


StandingB_NumBGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..StandingB_NumBGColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
全部屋同時表示時の立ち見B部屋コメント番号背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int StandingB_NumBGColor
Visual Basic
Public StandingB_NumBGColor As Integer
Visual C++
public:
int StandingB_NumBGColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


StandingC_NumBGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..StandingC_NumBGColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
全部屋同時表示時の立ち見C部屋コメント番号背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int StandingC_NumBGColor
Visual Basic
Public StandingC_NumBGColor As Integer
Visual C++
public:
int StandingC_NumBGColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


StandingD_NumBGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..StandingD_NumBGColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
全部屋同時表示時の立ち見D部屋コメント番号背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int StandingD_NumBGColor
Visual Basic
Public StandingD_NumBGColor As Integer
Visual C++
public:
int StandingD_NumBGColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


StandingE_NumBGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..StandingE_NumBGColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
全部屋同時表示時の立ち見E部屋コメント番号背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int StandingE_NumBGColor
Visual Basic
Public StandingE_NumBGColor As Integer
Visual C++
public:
int StandingE_NumBGColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


UserIDLinkColor Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting..::..UserIDLinkColor Field
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信
生IDリンク色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int UserIDLinkColor
Visual Basic
Public UserIDLinkColor As Integer
Visual C++
public:
int UserIDLinkColor

See Also

AppSettingInPlugin..::..DGVColorSetting Class


AppSettingInPlugin.DGVColorSetting Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..DGVColorSetting Methods
AppSettingInPlugin..::..DGVColorSetting Class See Also フィードバックの送信

The AppSettingInPlugin..::..DGVColorSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

AppSettingInPlugin..::..DGVColorSetting Class


AppSettingInPlugin.LoginUserSetting Class

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..LoginUserSetting Class
AppSettingInPlugin Class Members See Also フィードバックの送信
ログインユーザー設定

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class LoginUserSetting
Visual Basic
Public Class LoginUserSetting
Visual C++
public ref class LoginUserSetting

Inheritance Hierarchy

System..::..Object
Plugin..::..AppSettingInPlugin..::..LoginUserSetting

See Also

AppSettingInPlugin..::..LoginUserSetting Members


AppSettingInPlugin.LoginUserSetting Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..LoginUserSetting Members
AppSettingInPlugin..::..LoginUserSetting Class Constructors Methods Fields See Also フィードバックの送信

アプリケーション設定のコピークラス

The AppSettingInPlugin..::..LoginUserSetting type exposes the following members.

Constructors

 | Name | Description
Public method | AppSettingInPlugin..::..LoginUserSetting | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Fields

 | Name | Description
Public field | CookieSource | クッキー取得先ブラウザタイプ

See Also

AppSettingInPlugin..::..LoginUserSetting Class


AppSettingInPlugin.LoginUserSetting Constructor

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..LoginUserSetting Constructor
AppSettingInPlugin..::..LoginUserSetting Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public LoginUserSetting()
Visual Basic
Public Sub New
Visual C++
public:
LoginUserSetting()

See Also

AppSettingInPlugin..::..LoginUserSetting Class


AppSettingInPlugin.LoginUserSetting Fields

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..LoginUserSetting Fields
AppSettingInPlugin..::..LoginUserSetting Class See Also フィードバックの送信

The AppSettingInPlugin..::..LoginUserSetting type exposes the following members.

Fields

 | Name | Description
Public field | CookieSource | クッキー取得先ブラウザタイプ

See Also

AppSettingInPlugin..::..LoginUserSetting Class


CookieSource Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..LoginUserSetting..::..CookieSource Field
AppSettingInPlugin..::..LoginUserSetting Class See Also フィードバックの送信
クッキー取得先ブラウザタイプ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public CookieType CookieSource
Visual Basic
Public CookieSource As CookieType
Visual C++
public:
CookieType CookieSource

See Also

AppSettingInPlugin..::..LoginUserSetting Class


AppSettingInPlugin.LoginUserSetting Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..LoginUserSetting Methods
AppSettingInPlugin..::..LoginUserSetting Class See Also フィードバックの送信

The AppSettingInPlugin..::..LoginUserSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

AppSettingInPlugin..::..LoginUserSetting Class


AppSettingInPlugin.ReadingOutSetting Class

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting Class
AppSettingInPlugin Class Members See Also フィードバックの送信
コメント読み上げ設定

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class ReadingOutSetting
Visual Basic
Public Class ReadingOutSetting
Visual C++
public ref class ReadingOutSetting

Inheritance Hierarchy

System..::..Object
Plugin..::..AppSettingInPlugin..::..ReadingOutSetting

See Also

AppSettingInPlugin..::..ReadingOutSetting Members


AppSettingInPlugin.ReadingOutSetting Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting Members
AppSettingInPlugin..::..ReadingOutSetting Class Constructors Methods Fields See Also フィードバックの送信

アプリケーション設定のコピークラス

The AppSettingInPlugin..::..ReadingOutSetting type exposes the following members.

Constructors

 | Name | Description
Public method | AppSettingInPlugin..::..ReadingOutSetting | Initializes a new instance of the AppSettingInPlugin..::..ReadingOutSetting class

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Fields

 | Name | Description
Public field | AppType | 読み上げアプリ
Public field | BouyomityanAppPath | 棒読みちゃんの実行ファイル絶対パス
Public field | IsBSPReadOut | BSPコメントを読み上げるかどうか
Public field | IsNGWordReadOut | 運営NGワードに該当するコメントを読み上げるかどうか
Public field | IsNicknameReadOut | コメントを投稿したユーザーのニックネーム読み上げるかどうか
Public field | IsNotIncludeLinefeedReadOut | 改行を含むコメントを読み上げないかどうか（trueで読み上げない）
Public field | IsPresenterReadOut | 運営コメントを読み上げるかどうか
Public field | IsReadingOut | コメント読み上げ機能を使用するかどうか（これがtrueのとき受信コメントの読み上げが行なわれる）
Public field | IsReadingOutRestricted | コメントの文字数で読み上げ制限を行うかどうか
Public field | IsTelopReadOut | テロップコメントを読み上げるかどうか（ニコ生クルーズ・ニコニコ実況）
Public field | IsUserReadOut | 通常ユーザーコメントを読み上げるかどうか
Public field | LimitationNum | 読み上げ最大文字数
Public field | PostString | コメント省略時の後置文字
Public field | ReplaceEmptyRegex | 読み上げ時の除外文字列（正規表現）
Public field | ShareLevel | 共有NG制限
Public field | SofTalkAppPath | SafTalkの実行ファイル絶対パス

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


AppSettingInPlugin.ReadingOutSetting Constructor

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting Constructor
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
Initializes a new instance of the AppSettingInPlugin..::..ReadingOutSetting class

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public ReadingOutSetting()
Visual Basic
Public Sub New
Visual C++
public:
ReadingOutSetting()

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


AppSettingInPlugin.ReadingOutSetting Fields

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting Fields
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信

The AppSettingInPlugin..::..ReadingOutSetting type exposes the following members.

Fields

 | Name | Description
Public field | AppType | 読み上げアプリ
Public field | BouyomityanAppPath | 棒読みちゃんの実行ファイル絶対パス
Public field | IsBSPReadOut | BSPコメントを読み上げるかどうか
Public field | IsNGWordReadOut | 運営NGワードに該当するコメントを読み上げるかどうか
Public field | IsNicknameReadOut | コメントを投稿したユーザーのニックネーム読み上げるかどうか
Public field | IsNotIncludeLinefeedReadOut | 改行を含むコメントを読み上げないかどうか（trueで読み上げない）
Public field | IsPresenterReadOut | 運営コメントを読み上げるかどうか
Public field | IsReadingOut | コメント読み上げ機能を使用するかどうか（これがtrueのとき受信コメントの読み上げが行なわれる）
Public field | IsReadingOutRestricted | コメントの文字数で読み上げ制限を行うかどうか
Public field | IsTelopReadOut | テロップコメントを読み上げるかどうか（ニコ生クルーズ・ニコニコ実況）
Public field | IsUserReadOut | 通常ユーザーコメントを読み上げるかどうか
Public field | LimitationNum | 読み上げ最大文字数
Public field | PostString | コメント省略時の後置文字
Public field | ReplaceEmptyRegex | 読み上げ時の除外文字列（正規表現）
Public field | ShareLevel | 共有NG制限
Public field | SofTalkAppPath | SafTalkの実行ファイル絶対パス

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


AppType Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..AppType Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
読み上げアプリ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public ReadingOutApp AppType
Visual Basic
Public AppType As ReadingOutApp
Visual C++
public:
ReadingOutApp AppType

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


BouyomityanAppPath Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..BouyomityanAppPath Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
棒読みちゃんの実行ファイル絶対パス

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string BouyomityanAppPath
Visual Basic
Public BouyomityanAppPath As String
Visual C++
public:
String^ BouyomityanAppPath

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsBSPReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsBSPReadOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
BSPコメントを読み上げるかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsBSPReadOut
Visual Basic
Public IsBSPReadOut As Boolean
Visual C++
public:
bool IsBSPReadOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsNGWordReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsNGWordReadOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
運営NGワードに該当するコメントを読み上げるかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsNGWordReadOut
Visual Basic
Public IsNGWordReadOut As Boolean
Visual C++
public:
bool IsNGWordReadOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsNicknameReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsNicknameReadOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
コメントを投稿したユーザーのニックネーム読み上げるかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsNicknameReadOut
Visual Basic
Public IsNicknameReadOut As Boolean
Visual C++
public:
bool IsNicknameReadOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsNotIncludeLinefeedReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsNotIncludeLinefeedReadOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
改行を含むコメントを読み上げないかどうか（trueで読み上げない）

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsNotIncludeLinefeedReadOut
Visual Basic
Public IsNotIncludeLinefeedReadOut As Boolean
Visual C++
public:
bool IsNotIncludeLinefeedReadOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsPresenterReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsPresenterReadOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
運営コメントを読み上げるかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsPresenterReadOut
Visual Basic
Public IsPresenterReadOut As Boolean
Visual C++
public:
bool IsPresenterReadOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsReadingOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsReadingOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
コメント読み上げ機能を使用するかどうか（これがtrueのとき受信コメントの読み上げが行なわれる）

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsReadingOut
Visual Basic
Public IsReadingOut As Boolean
Visual C++
public:
bool IsReadingOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsReadingOutRestricted Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsReadingOutRestricted Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
コメントの文字数で読み上げ制限を行うかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsReadingOutRestricted
Visual Basic
Public IsReadingOutRestricted As Boolean
Visual C++
public:
bool IsReadingOutRestricted

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsTelopReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsTelopReadOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
テロップコメントを読み上げるかどうか（ニコ生クルーズ・ニコニコ実況）

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsTelopReadOut
Visual Basic
Public IsTelopReadOut As Boolean
Visual C++
public:
bool IsTelopReadOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


IsUserReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..IsUserReadOut Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
通常ユーザーコメントを読み上げるかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsUserReadOut
Visual Basic
Public IsUserReadOut As Boolean
Visual C++
public:
bool IsUserReadOut

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


LimitationNum Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..LimitationNum Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
読み上げ最大文字数

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int LimitationNum
Visual Basic
Public LimitationNum As Integer
Visual C++
public:
int LimitationNum

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


PostString Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..PostString Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
コメント省略時の後置文字

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string PostString
Visual Basic
Public PostString As String
Visual C++
public:
String^ PostString

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


ReplaceEmptyRegex Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..ReplaceEmptyRegex Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
読み上げ時の除外文字列（正規表現）

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string ReplaceEmptyRegex
Visual Basic
Public ReplaceEmptyRegex As String
Visual C++
public:
String^ ReplaceEmptyRegex

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


ShareLevel Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..ShareLevel Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
共有NG制限

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public NGShareLevels ShareLevel
Visual Basic
Public ShareLevel As NGShareLevels
Visual C++
public:
NGShareLevels ShareLevel

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


SofTalkAppPath Field

[image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting..::..SofTalkAppPath Field
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信
SafTalkの実行ファイル絶対パス

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string SofTalkAppPath
Visual Basic
Public SofTalkAppPath As String
Visual C++
public:
String^ SofTalkAppPath

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


AppSettingInPlugin.ReadingOutSetting Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
AppSettingInPlugin..::..ReadingOutSetting Methods
AppSettingInPlugin..::..ReadingOutSetting Class See Also フィードバックの送信

The AppSettingInPlugin..::..ReadingOutSetting type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

AppSettingInPlugin..::..ReadingOutSetting Class


BroadcastConnectedEventHandler Delegate

[image]

NiconamaCommentViwer Plug-in Documents
BroadcastConnectedEventHandler Delegate
See Also フィードバックの送信
BroadcastConnectedイベントのデリゲート

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public delegate void BroadcastConnectedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub BroadcastConnectedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void BroadcastConnectedEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Plugin Namespace


BroadcastDisConnectedEventHandler Delegate

[image]

NiconamaCommentViwer Plug-in Documents
BroadcastDisConnectedEventHandler Delegate
See Also フィードバックの送信
BroadcastDisConnectedイベントのデリゲート

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public delegate void BroadcastDisConnectedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub BroadcastDisConnectedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void BroadcastDisConnectedEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Plugin Namespace


CommentLogOpenedEventHandler Delegate

[image]

NiconamaCommentViwer Plug-in Documents
CommentLogOpenedEventHandler Delegate
See Also フィードバックの送信
CommentLogOpenedイベントのデリゲート

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public delegate void CommentLogOpenedEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic
Public Delegate Sub CommentLogOpenedEventHandler ( _
    sender As Object, _
    e As EventArgs _
)
Visual C++
public delegate void CommentLogOpenedEventHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: System..::..EventArgs

See Also

Plugin Namespace


ConfigureOriginalNGWordInPlugin Class

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin Class
Members See Also フィードバックの送信
NG設定

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class ConfigureOriginalNGWordInPlugin
Visual Basic
Public Class ConfigureOriginalNGWordInPlugin
Visual C++
public ref class ConfigureOriginalNGWordInPlugin

Inheritance Hierarchy

System..::..Object
Plugin..::..ConfigureOriginalNGWordInPlugin

See Also

ConfigureOriginalNGWordInPlugin Members


ConfigureOriginalNGWordInPlugin Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin Members
ConfigureOriginalNGWordInPlugin Class Constructors Methods Properties See Also フィードバックの送信

The ConfigureOriginalNGWordInPlugin type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigureOriginalNGWordInPlugin()()()() | コンストラクタ
Public method | ConfigureOriginalNGWordInPlugin(List<(Of <<'(ConfigureOriginalNGWordInPlugin..::..NGClient>)>>), Int32, Int32) |

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | MergeNGClientList |
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | NGClientList | NG設定リスト
Public property | NGUserNum | NGユーザー登録数
Public property | NGWordNum | NGワード登録数

See Also

ConfigureOriginalNGWordInPlugin Class


ConfigureOriginalNGWordInPlugin Constructor

[image] [image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin Constructor
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | ConfigureOriginalNGWordInPlugin()()()() | コンストラクタ
Public method | ConfigureOriginalNGWordInPlugin(List<(Of <<'(ConfigureOriginalNGWordInPlugin..::..NGClient>)>>), Int32, Int32) | Initializes a new instance of the ConfigureOriginalNGWordInPlugin class

See Also

ConfigureOriginalNGWordInPlugin Class
ConfigureOriginalNGWordInPlugin Members


ConfigureOriginalNGWordInPlugin Constructor

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin Constructor
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public ConfigureOriginalNGWordInPlugin()
Visual Basic
Public Sub New
Visual C++
public:
ConfigureOriginalNGWordInPlugin()

See Also

ConfigureOriginalNGWordInPlugin Class
ConfigureOriginalNGWordInPlugin Overload


ConfigureOriginalNGWordInPlugin Constructor (List(ConfigureOriginalNGWordInPlugin.NGClient), Int32, Int32)

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin Constructor (List<(Of <(<'ConfigureOriginalNGWordInPlugin..::..NGClient>)>)>, Int32, Int32)
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信
Initializes a new instance of the ConfigureOriginalNGWordInPlugin class

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public ConfigureOriginalNGWordInPlugin(
    List<ConfigureOriginalNGWordInPlugin..::..NGClient> ngClientList,
    int ngWordNum,
    int ngUserNum
)
Visual Basic
Public Sub New ( _
    ngClientList As List(Of ConfigureOriginalNGWordInPlugin..::..NGClient), _
    ngWordNum As Integer, _
    ngUserNum As Integer _
)
Visual C++
public:
ConfigureOriginalNGWordInPlugin(
    List<ConfigureOriginalNGWordInPlugin..::..NGClient^>^ ngClientList,
    int ngWordNum,
    int ngUserNum
)

Parameters

ngClientList
Type: System.Collections.Generic..::..List <(Of <(<' ConfigureOriginalNGWordInPlugin..::..NGClient >)>)>

[Missing <param name="ngClientList"/> documentation for "M:Plugin.ConfigureOriginalNGWordInPlugin.#ctor(System.Collections.Generic.List{Plugin.ConfigureOriginalNGWordInPlugin.NGClient},System.Int32,System.Int32)"]

ngWordNum
Type: System..::..Int32

[Missing <param name="ngWordNum"/> documentation for "M:Plugin.ConfigureOriginalNGWordInPlugin.#ctor(System.Collections.Generic.List{Plugin.ConfigureOriginalNGWordInPlugin.NGClient},System.Int32,System.Int32)"]

ngUserNum
Type: System..::..Int32

[Missing <param name="ngUserNum"/> documentation for "M:Plugin.ConfigureOriginalNGWordInPlugin.#ctor(System.Collections.Generic.List{Plugin.ConfigureOriginalNGWordInPlugin.NGClient},System.Int32,System.Int32)"]

See Also

ConfigureOriginalNGWordInPlugin Class
ConfigureOriginalNGWordInPlugin Overload


ConfigureOriginalNGWordInPlugin Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin Methods
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信

The ConfigureOriginalNGWordInPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | MergeNGClientList |
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

ConfigureOriginalNGWordInPlugin Class


MergeNGClientList Method

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..MergeNGClientList Method
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信

[Missing <summary> documentation for "M:Plugin.ConfigureOriginalNGWordInPlugin.MergeNGClientList(System.Collections.Generic.List{Plugin.ConfigureOriginalNGWordInPlugin.NGClient},System.Int32,System.Int32)"]

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public void MergeNGClientList(
    List<ConfigureOriginalNGWordInPlugin..::..NGClient> ngClientList,
    int ngWordNum,
    int ngUserNum
)
Visual Basic
Public Sub MergeNGClientList ( _
    ngClientList As List(Of ConfigureOriginalNGWordInPlugin..::..NGClient), _
    ngWordNum As Integer, _
    ngUserNum As Integer _
)
Visual C++
public:
void MergeNGClientList(
    List<ConfigureOriginalNGWordInPlugin..::..NGClient^>^ ngClientList,
    int ngWordNum,
    int ngUserNum
)

Parameters

ngClientList
Type: System.Collections.Generic..::..List <(Of <(<' ConfigureOriginalNGWordInPlugin..::..NGClient >)>)>

[Missing <param name="ngClientList"/> documentation for "M:Plugin.ConfigureOriginalNGWordInPlugin.MergeNGClientList(System.Collections.Generic.List{Plugin.ConfigureOriginalNGWordInPlugin.NGClient},System.Int32,System.Int32)"]

ngWordNum
Type: System..::..Int32

[Missing <param name="ngWordNum"/> documentation for "M:Plugin.ConfigureOriginalNGWordInPlugin.MergeNGClientList(System.Collections.Generic.List{Plugin.ConfigureOriginalNGWordInPlugin.NGClient},System.Int32,System.Int32)"]

ngUserNum
Type: System..::..Int32

[Missing <param name="ngUserNum"/> documentation for "M:Plugin.ConfigureOriginalNGWordInPlugin.MergeNGClientList(System.Collections.Generic.List{Plugin.ConfigureOriginalNGWordInPlugin.NGClient},System.Int32,System.Int32)"]

See Also

ConfigureOriginalNGWordInPlugin Class


ConfigureOriginalNGWordInPlugin Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin Properties
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信

The ConfigureOriginalNGWordInPlugin type exposes the following members.

Properties

 | Name | Description
Public property | NGClientList | NG設定リスト
Public property | NGUserNum | NGユーザー登録数
Public property | NGWordNum | NGワード登録数

See Also

ConfigureOriginalNGWordInPlugin Class


NGClientList Property

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClientList Property
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信
NG設定リスト

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public List<ConfigureOriginalNGWordInPlugin..::..NGClient> NGClientList { get; }
Visual Basic
Public ReadOnly Property NGClientList As List(Of ConfigureOriginalNGWordInPlugin..::..NGClient)
    Get
Visual C++
public:
property List<ConfigureOriginalNGWordInPlugin..::..NGClient^>^ NGClientList {
    List<ConfigureOriginalNGWordInPlugin..::..NGClient^>^ get ();
}

See Also

ConfigureOriginalNGWordInPlugin Class


NGUserNum Property

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGUserNum Property
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信
NGユーザー登録数

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int NGUserNum { get; }
Visual Basic
Public ReadOnly Property NGUserNum As Integer
    Get
Visual C++
public:
property int NGUserNum {
    int get ();
}

See Also

ConfigureOriginalNGWordInPlugin Class


NGWordNum Property

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGWordNum Property
ConfigureOriginalNGWordInPlugin Class See Also フィードバックの送信
NGワード登録数

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public int NGWordNum { get; }
Visual Basic
Public ReadOnly Property NGWordNum As Integer
    Get
Visual C++
public:
property int NGWordNum {
    int get ();
}

See Also

ConfigureOriginalNGWordInPlugin Class


ConfigureOriginalNGWordInPlugin.NGClient Class

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient Class
ConfigureOriginalNGWordInPlugin Class Members See Also フィードバックの送信
NG設定格納用構造体

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class NGClient
Visual Basic
Public Class NGClient
Visual C++
public ref class NGClient

Inheritance Hierarchy

System..::..Object
Plugin..::..ConfigureOriginalNGWordInPlugin..::..NGClient

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Members


ConfigureOriginalNGWordInPlugin.NGClient Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient Members
ConfigureOriginalNGWordInPlugin..::..NGClient Class Constructors Methods Fields See Also フィードバックの送信

NG設定

The ConfigureOriginalNGWordInPlugin..::..NGClient type exposes the following members.

Constructors

 | Name | Description
Public method | ConfigureOriginalNGWordInPlugin..::..NGClient | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Fields

 | Name | Description
Public field | IsRegex | 正規表現かどうか
Public field | RegisterTime | 登録日時
Public field | Source | NG対象文字列
Public field | Type | NGタイプ

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


ConfigureOriginalNGWordInPlugin.NGClient Constructor

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient Constructor
ConfigureOriginalNGWordInPlugin..::..NGClient Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public NGClient()
Visual Basic
Public Sub New
Visual C++
public:
NGClient()

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


ConfigureOriginalNGWordInPlugin.NGClient Fields

[image] [image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient Fields
ConfigureOriginalNGWordInPlugin..::..NGClient Class See Also フィードバックの送信

The ConfigureOriginalNGWordInPlugin..::..NGClient type exposes the following members.

Fields

 | Name | Description
Public field | IsRegex | 正規表現かどうか
Public field | RegisterTime | 登録日時
Public field | Source | NG対象文字列
Public field | Type | NGタイプ

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


IsRegex Field

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient..::..IsRegex Field
ConfigureOriginalNGWordInPlugin..::..NGClient Class See Also フィードバックの送信
正規表現かどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsRegex
Visual Basic
Public IsRegex As Boolean
Visual C++
public:
bool IsRegex

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


RegisterTime Field

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient..::..RegisterTime Field
ConfigureOriginalNGWordInPlugin..::..NGClient Class See Also フィードバックの送信
登録日時

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string RegisterTime
Visual Basic
Public RegisterTime As String
Visual C++
public:
String^ RegisterTime

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


Source Field

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient..::..Source Field
ConfigureOriginalNGWordInPlugin..::..NGClient Class See Also フィードバックの送信
NG対象文字列

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string Source
Visual Basic
Public Source As String
Visual C++
public:
String^ Source

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


Type Field

[image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient..::..Type Field
ConfigureOriginalNGWordInPlugin..::..NGClient Class See Also フィードバックの送信
NGタイプ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public NGType Type
Visual Basic
Public Type As NGType
Visual C++
public:
NGType Type

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


ConfigureOriginalNGWordInPlugin.NGClient Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
ConfigureOriginalNGWordInPlugin..::..NGClient Methods
ConfigureOriginalNGWordInPlugin..::..NGClient Class See Also フィードバックの送信

The ConfigureOriginalNGWordInPlugin..::..NGClient type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

ConfigureOriginalNGWordInPlugin..::..NGClient Class


HeartBeatUpdatedEventArgs Class

[image]

NiconamaCommentViwer Plug-in Documents
HeartBeatUpdatedEventArgs Class
Members See Also フィードバックの送信
HeartBeatUpdatedイベントのデータ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class HeartBeatUpdatedEventArgs : EventArgs
Visual Basic
Public Class HeartBeatUpdatedEventArgs _
    Inherits EventArgs
Visual C++
public ref class HeartBeatUpdatedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Plugin..::..HeartBeatUpdatedEventArgs

See Also

HeartBeatUpdatedEventArgs Members


HeartBeatUpdatedEventArgs Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
HeartBeatUpdatedEventArgs Members
HeartBeatUpdatedEventArgs Class Constructors Methods Properties See Also フィードバックの送信

The HeartBeatUpdatedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | HeartBeatUpdatedEventArgs | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | HeartBeat | HeartBeatデータ

See Also

HeartBeatUpdatedEventArgs Class


HeartBeatUpdatedEventArgs Constructor

[image]

NiconamaCommentViwer Plug-in Documents
HeartBeatUpdatedEventArgs Constructor
HeartBeatUpdatedEventArgs Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public HeartBeatUpdatedEventArgs(
    NicoLiveHeartBeat heartBeat
)
Visual Basic
Public Sub New ( _
    heartBeat As NicoLiveHeartBeat _
)
Visual C++
public:
HeartBeatUpdatedEventArgs(
    NicoLiveHeartBeat^ heartBeat
)

Parameters

heartBeat
Type: NicoLiveHeartBeat
HeartBeatデータ

See Also

HeartBeatUpdatedEventArgs Class


HeartBeatUpdatedEventArgs Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
HeartBeatUpdatedEventArgs Methods
HeartBeatUpdatedEventArgs Class See Also フィードバックの送信

The HeartBeatUpdatedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

HeartBeatUpdatedEventArgs Class


HeartBeatUpdatedEventArgs Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
HeartBeatUpdatedEventArgs Properties
HeartBeatUpdatedEventArgs Class See Also フィードバックの送信

The HeartBeatUpdatedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | HeartBeat | HeartBeatデータ

See Also

HeartBeatUpdatedEventArgs Class


HeartBeat Property

[image]

NiconamaCommentViwer Plug-in Documents
HeartBeatUpdatedEventArgs..::..HeartBeat Property
HeartBeatUpdatedEventArgs Class See Also フィードバックの送信
HeartBeatデータ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public NicoLiveHeartBeat HeartBeat { get; }
Visual Basic
Public ReadOnly Property HeartBeat As NicoLiveHeartBeat
    Get
Visual C++
public:
property NicoLiveHeartBeat^ HeartBeat {
    NicoLiveHeartBeat^ get ();
}

See Also

HeartBeatUpdatedEventArgs Class


HeartBeatUpdatedEventHandler Delegate

[image]

NiconamaCommentViwer Plug-in Documents
HeartBeatUpdatedEventHandler Delegate
See Also フィードバックの送信
HeartBeatUpdatedイベントのデリゲート

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public delegate void HeartBeatUpdatedEventHandler(
    Object sender,
    HeartBeatUpdatedEventArgs e
)
Visual Basic
Public Delegate Sub HeartBeatUpdatedEventHandler ( _
    sender As Object, _
    e As HeartBeatUpdatedEventArgs _
)
Visual C++
public delegate void HeartBeatUpdatedEventHandler(
    Object^ sender,
    HeartBeatUpdatedEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: Plugin..::..HeartBeatUpdatedEventArgs

See Also

Plugin Namespace


IPlugin Interface

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin Interface
Members See Also フィードバックの送信
プラグインで実装するインターフェイス

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public interface IPlugin
Visual Basic
Public Interface IPlugin
Visual C++
public interface class IPlugin

See Also

IPlugin Members


IPlugin Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPlugin Members
IPlugin Interface Methods Properties See Also フィードバックの送信

The IPlugin type exposes the following members.

Methods

 | Name | Description
Public method | AutoRun | アプリケーション起動時にプラグインを自動実行する
Public method | Run | プラグインを実行する

Properties

 | Name | Description
Public property | Description | プラグインの説明
Public property | Host | プラグインのホスト
Public property | IsAutoRun | アプリケーション起動時にプラグインを自動実行するかどうか
Public property | Name | プラグインの名前
Public property | Version | プラグインのバージョン

See Also

IPlugin Interface


IPlugin Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPlugin Methods
IPlugin Interface See Also フィードバックの送信

The IPlugin type exposes the following members.

Methods

 | Name | Description
Public method | AutoRun | アプリケーション起動時にプラグインを自動実行する
Public method | Run | プラグインを実行する

See Also

IPlugin Interface


AutoRun Method

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin..::..AutoRun Method
IPlugin Interface See Also フィードバックの送信
アプリケーション起動時にプラグインを自動実行する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void AutoRun()
Visual Basic
Sub AutoRun
Visual C++
void AutoRun()

Remarks

IsAutoRunがtrueの場合、アプリケーション起動時に自動実行されます。

実行されるタイミングはメインフォームのLoadイベントですべてのプラグインが読み込まれた直後です。

See Also

IPlugin Interface


Run Method

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin..::..Run Method
IPlugin Interface See Also フィードバックの送信
プラグインを実行する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void Run()
Visual Basic
Sub Run
Visual C++
void Run()

See Also

IPlugin Interface


IPlugin Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPlugin Properties
IPlugin Interface See Also フィードバックの送信

The IPlugin type exposes the following members.

Properties

 | Name | Description
Public property | Description | プラグインの説明
Public property | Host | プラグインのホスト
Public property | IsAutoRun | アプリケーション起動時にプラグインを自動実行するかどうか
Public property | Name | プラグインの名前
Public property | Version | プラグインのバージョン

See Also

IPlugin Interface


Description Property

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin..::..Description Property
IPlugin Interface See Also フィードバックの送信
プラグインの説明

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
string Description { get; }
Visual Basic
ReadOnly Property Description As String
    Get
Visual C++
property String^ Description {
    String^ get ();
}

See Also

IPlugin Interface


Host Property

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin..::..Host Property
IPlugin Interface See Also フィードバックの送信
プラグインのホスト

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
IPluginHost Host { get; set; }
Visual Basic
Property Host As IPluginHost
    Get
    Set
Visual C++
property IPluginHost^ Host {
    IPluginHost^ get ();
    void set (IPluginHost^ value);
}

See Also

IPlugin Interface


IsAutoRun Property

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin..::..IsAutoRun Property
IPlugin Interface See Also フィードバックの送信
アプリケーション起動時にプラグインを自動実行するかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool IsAutoRun { get; }
Visual Basic
ReadOnly Property IsAutoRun As Boolean
    Get
Visual C++
property bool IsAutoRun {
    bool get ();
}

See Also

IPlugin Interface


Name Property

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin..::..Name Property
IPlugin Interface See Also フィードバックの送信
プラグインの名前

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get
Visual C++
property String^ Name {
    String^ get ();
}

See Also

IPlugin Interface


Version Property

[image]

NiconamaCommentViwer Plug-in Documents
IPlugin..::..Version Property
IPlugin Interface See Also フィードバックの送信
プラグインのバージョン

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
string Version { get; }
Visual Basic
ReadOnly Property Version As String
    Get
Visual C++
property String^ Version {
    String^ get ();
}

See Also

IPlugin Interface


IPluginEx Interface

[image]

NiconamaCommentViwer Plug-in Documents
IPluginEx Interface
Members See Also フィードバックの送信
プラグインで実装するインターフェイス（メインメニューの「設定」項目からプラグイン設定を実行できる）

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public interface IPluginEx : IPlugin
Visual Basic
Public Interface IPluginEx _
    Inherits IPlugin
Visual C++
public interface class IPluginEx : IPlugin

See Also

IPluginEx Members


IPluginEx Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginEx Members
IPluginEx Interface Methods Properties See Also フィードバックの送信

The IPluginEx type exposes the following members.

Methods

 | Name | Description
Public method | AutoRun | アプリケーション起動時にプラグインを自動実行する (Inherited from IPlugin.)
Public method | Run | プラグインを実行する (Inherited from IPlugin.)
Public method | ShowSettingForm | プラグイン設定処理を実行する

Properties

 | Name | Description
Public property | Description | プラグインの説明 (Inherited from IPlugin.)
Public property | HasSettingForm | メインメニューの「設定」項目にプラグイン設定実行項目を表示するかどうか
Public property | Host | プラグインのホスト (Inherited from IPlugin.)
Public property | IsAutoRun | アプリケーション起動時にプラグインを自動実行するかどうか (Inherited from IPlugin.)
Public property | Name | プラグインの名前 (Inherited from IPlugin.)
Public property | Version | プラグインのバージョン (Inherited from IPlugin.)

See Also

IPluginEx Interface


IPluginEx Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginEx Methods
IPluginEx Interface See Also フィードバックの送信

The IPluginEx type exposes the following members.

Methods

 | Name | Description
Public method | AutoRun | アプリケーション起動時にプラグインを自動実行する (Inherited from IPlugin.)
Public method | Run | プラグインを実行する (Inherited from IPlugin.)
Public method | ShowSettingForm | プラグイン設定処理を実行する

See Also

IPluginEx Interface


ShowSettingForm Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginEx..::..ShowSettingForm Method
IPluginEx Interface See Also フィードバックの送信
プラグイン設定処理を実行する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void ShowSettingForm()
Visual Basic
Sub ShowSettingForm
Visual C++
void ShowSettingForm()

See Also

IPluginEx Interface


IPluginEx Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginEx Properties
IPluginEx Interface See Also フィードバックの送信

The IPluginEx type exposes the following members.

Properties

 | Name | Description
Public property | Description | プラグインの説明 (Inherited from IPlugin.)
Public property | HasSettingForm | メインメニューの「設定」項目にプラグイン設定実行項目を表示するかどうか
Public property | Host | プラグインのホスト (Inherited from IPlugin.)
Public property | IsAutoRun | アプリケーション起動時にプラグインを自動実行するかどうか (Inherited from IPlugin.)
Public property | Name | プラグインの名前 (Inherited from IPlugin.)
Public property | Version | プラグインのバージョン (Inherited from IPlugin.)

See Also

IPluginEx Interface


HasSettingForm Property

[image]

NiconamaCommentViwer Plug-in Documents
IPluginEx..::..HasSettingForm Property
IPluginEx Interface See Also フィードバックの送信
メインメニューの「設定」項目にプラグイン設定実行項目を表示するかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool HasSettingForm { get; }
Visual Basic
ReadOnly Property HasSettingForm As Boolean
    Get
Visual C++
property bool HasSettingForm {
    bool get ();
}

See Also

IPluginEx Interface


IPluginHost Interface

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost Interface
Members See Also フィードバックの送信
プラグインのホストで実装するインターフェイス

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public interface IPluginHost
Visual Basic
Public Interface IPluginHost
Visual C++
public interface class IPluginHost

See Also

IPluginHost Members


IPluginHost Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost Members
IPluginHost Interface Methods Properties Events See Also フィードバックの送信

The IPluginHost type exposes the following members.

Methods

 | Name | Description
Public method | AddUserSettingInPlugin | ユーザー設定を追加する
Public method | ConnectLive | 放送に接続する
Public method | DeleteUserSettingInPlugin | ユーザー設定を削除する
Public method | DisconnectLive | 放送を切断する
Public method | EditUserSettingInPlugin | ユーザー設定を編集する
Public method | GetAcquiredComment | 受信済みのコメントをすべて取得する
Public method | GetApplicationSetting | アプリケーション設定データを取得する
Public method | GetElapsedTime | 接続している放送の経過時間を取得する
Public method | GetHeartBeat | 現在保持しているHeartBeat情報を取得する
Public method | GetLiveInfo | 接続中放送の放送情報を取得する
Public method | GetOriginalNGWordInPlugin | NG設定リストを取得する
Public method | GetPlayerStatus | 接続中放送のPlayerStatusを取得する
Public method | GetPublishStatus | 接続中放送のPublishStatusを取得する
Public method | GetSelectedCommentData | 現在選択中のコメントデータを取得する
Public method | GetUserSettingInPlugin | ユーザー設定リストを取得する
Public method | GetVersionInfo | NiconamaCommentViewerのバージョン情報を取得する
Public method | OpenCommentLog | コメントログファイルを開く メインウィンドウの「ファイル→開く」を実行し、openFileDialogが開かれる
Public method | ReadAloudInPlugin | オプションで設定されている読み上げツールで指定した文字列を読み上げる
Public method | SendComment(String) | メインウィンドウで選択されているパラメータを使用して通常コメントを送信する
Public method | SendComment(String, String) | コマンド文字列を指定して通常コメントを送信する
Public method | SendComment(Boolean, String, String, String, String) | パラメータを指定して通常コメントを送信する
Public method | SendOwnerComment(String) | メインウィンドウで選択されているパラメータを使用して運営コメントを送信する
Public method | SendOwnerComment(String, String, String) | コマンド文字列を指定して運営コメントを送信する
Public method | SendOwnerComment(Boolean, String, String, String, String, String, String) | パラメータを指定して運営コメントを送信する
Public method | SendPresscastComment(String) | メインウィンドウで選択されているパラメータを使用してBSPコメントを送信する
Public method | SendPresscastComment(String, String, String) | パラメータを指定してBSPコメントを送信する
Public method | SetRightclickMenuItemsInCommentDGV | データグリッドビューの右クリックメニューに項目を追加する
Public method | ShowMessageToStatusLabel(IPlugin, String) | メインウィンドウのステータスバーにメッセージを表示する
Public method | ShowMessageToStatusLabel(IPlugin, String, Color) | メインウィンドウのステータスバーにメッセージを表示する

Properties

 | Name | Description
Public property | DirectoryPathAppSetting | アプリケーション設定保存フォルダの場所を取得する
Public property | DirectoryPathCommentLogFile | コメントログファイル保存フォルダの場所を取得する
Public property | DirectoryPathSettingFile | 設定ファイル保存フォルダの場所を取得する
Public property | IsConnected | コメントサーバーに接続しているかどうか
Public property | MainForm | ホストのメインフォーム

Events

 | Name | Description
Public event | BroadcastConnected | 放送接続直後に発生するイベント
Public event | BroadcastDisConnected | 放送終了直後に発生するイベント
Public event | CommentLogOpened | コメントログファイルオープン時に発生するイベント
Public event | HeartBeatUpdated | HeartBeat取得時に発生するイベント
Public event | ReceivedComment | コメント受信時に発生するイベント
Public event | SettingDirectoryChanged | 設定ファイル保存フォルダ変更時に発生するイベント
Public event | WaybackCommentReceived | 過去コメント1000件受信時に発生するイベント 最小コメ番の書き込み時間を基準に1000件遡るため、既得コメントと重複したコメントが含まれている可能性もある

See Also

IPluginHost Interface


IPluginHost Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost Methods
IPluginHost Interface See Also フィードバックの送信

The IPluginHost type exposes the following members.

Methods

 | Name | Description
Public method | AddUserSettingInPlugin | ユーザー設定を追加する
Public method | ConnectLive | 放送に接続する
Public method | DeleteUserSettingInPlugin | ユーザー設定を削除する
Public method | DisconnectLive | 放送を切断する
Public method | EditUserSettingInPlugin | ユーザー設定を編集する
Public method | GetAcquiredComment | 受信済みのコメントをすべて取得する
Public method | GetApplicationSetting | アプリケーション設定データを取得する
Public method | GetElapsedTime | 接続している放送の経過時間を取得する
Public method | GetHeartBeat | 現在保持しているHeartBeat情報を取得する
Public method | GetLiveInfo | 接続中放送の放送情報を取得する
Public method | GetOriginalNGWordInPlugin | NG設定リストを取得する
Public method | GetPlayerStatus | 接続中放送のPlayerStatusを取得する
Public method | GetPublishStatus | 接続中放送のPublishStatusを取得する
Public method | GetSelectedCommentData | 現在選択中のコメントデータを取得する
Public method | GetUserSettingInPlugin | ユーザー設定リストを取得する
Public method | GetVersionInfo | NiconamaCommentViewerのバージョン情報を取得する
Public method | OpenCommentLog | コメントログファイルを開く メインウィンドウの「ファイル→開く」を実行し、openFileDialogが開かれる
Public method | ReadAloudInPlugin | オプションで設定されている読み上げツールで指定した文字列を読み上げる
Public method | SendComment(String) | メインウィンドウで選択されているパラメータを使用して通常コメントを送信する
Public method | SendComment(String, String) | コマンド文字列を指定して通常コメントを送信する
Public method | SendComment(Boolean, String, String, String, String) | パラメータを指定して通常コメントを送信する
Public method | SendOwnerComment(String) | メインウィンドウで選択されているパラメータを使用して運営コメントを送信する
Public method | SendOwnerComment(String, String, String) | コマンド文字列を指定して運営コメントを送信する
Public method | SendOwnerComment(Boolean, String, String, String, String, String, String) | パラメータを指定して運営コメントを送信する
Public method | SendPresscastComment(String) | メインウィンドウで選択されているパラメータを使用してBSPコメントを送信する
Public method | SendPresscastComment(String, String, String) | パラメータを指定してBSPコメントを送信する
Public method | SetRightclickMenuItemsInCommentDGV | データグリッドビューの右クリックメニューに項目を追加する
Public method | ShowMessageToStatusLabel(IPlugin, String) | メインウィンドウのステータスバーにメッセージを表示する
Public method | ShowMessageToStatusLabel(IPlugin, String, Color) | メインウィンドウのステータスバーにメッセージを表示する

See Also

IPluginHost Interface


AddUserSettingInPlugin Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..AddUserSettingInPlugin Method
IPluginHost Interface See Also フィードバックの送信
ユーザー設定を追加する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool AddUserSettingInPlugin(
    UserSettingInPlugin..::..UserData userData
)
Visual Basic
Function AddUserSettingInPlugin ( _
    userData As UserSettingInPlugin..::..UserData _
) As Boolean
Visual C++
bool AddUserSettingInPlugin(
    UserSettingInPlugin..::..UserData^ userData
)

Parameters

userData
Type: Plugin..::..UserSettingInPlugin..::..UserData
ユーザーデータ

Return Value

ユーザー設定追加処理が成功したかどうか

See Also

IPluginHost Interface


ConnectLive Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..ConnectLive Method
IPluginHost Interface See Also フィードバックの送信
放送に接続する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void ConnectLive(
    string liveNumber
)
Visual Basic
Sub ConnectLive ( _
    liveNumber As String _
)
Visual C++
void ConnectLive(
    String^ liveNumber
)

Parameters

liveNumber
Type: System..::..String
放送番号

番号を含んでいればアドレスなどどんな文字列でも可。

番号のみの場合は"lv"番号として処理される。チャンネル番号、コミュニティ番号の場合は番号の前にそれぞれ"ch"、"co"が必須。

See Also

IPluginHost Interface


DeleteUserSettingInPlugin Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..DeleteUserSettingInPlugin Method
IPluginHost Interface See Also フィードバックの送信
ユーザー設定を削除する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool DeleteUserSettingInPlugin(
    string userId,
    string communityNum
)
Visual Basic
Function DeleteUserSettingInPlugin ( _
    userId As String, _
    communityNum As String _
) As Boolean
Visual C++
bool DeleteUserSettingInPlugin(
    String^ userId,
    String^ communityNum
)

Parameters

userId
Type: System..::..String
ユーザーID
communityNum
Type: System..::..String
コミュニティ番号

コミュニティまたはチャンネルに依存したユーザー設定を指定したい場合は、"ch"または"co"から始まるコミュニティ番号を渡す。

Return Value

ユーザー設定削除処理が成功したかどうか

See Also

IPluginHost Interface


DisconnectLive Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..DisconnectLive Method
IPluginHost Interface See Also フィードバックの送信
放送を切断する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void DisconnectLive()
Visual Basic
Sub DisconnectLive
Visual C++
void DisconnectLive()

See Also

IPluginHost Interface


EditUserSettingInPlugin Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..EditUserSettingInPlugin Method
IPluginHost Interface See Also フィードバックの送信
ユーザー設定を編集する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool EditUserSettingInPlugin(
    UserSettingInPlugin..::..UserData userData
)
Visual Basic
Function EditUserSettingInPlugin ( _
    userData As UserSettingInPlugin..::..UserData _
) As Boolean
Visual C++
bool EditUserSettingInPlugin(
    UserSettingInPlugin..::..UserData^ userData
)

Parameters

userData
Type: Plugin..::..UserSettingInPlugin..::..UserData
ユーザーデータ

Return Value

ユーザー設定編集処理が成功したかどうか

See Also

IPluginHost Interface


GetAcquiredComment Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetAcquiredComment Method
IPluginHost Interface See Also フィードバックの送信
受信済みのコメントをすべて取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
List<LiveCommentData> GetAcquiredComment()
Visual Basic
Function GetAcquiredComment As List(Of LiveCommentData)
Visual C++
List<LiveCommentData^>^ GetAcquiredComment()

Return Value

受信済みのコメントデータリスト

See Also

IPluginHost Interface


GetApplicationSetting Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetApplicationSetting Method
IPluginHost Interface See Also フィードバックの送信
アプリケーション設定データを取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
AppSettingInPlugin GetApplicationSetting()
Visual Basic
Function GetApplicationSetting As AppSettingInPlugin
Visual C++
AppSettingInPlugin^ GetApplicationSetting()

Return Value

アプリケーション設定データ

See Also

IPluginHost Interface


GetElapsedTime Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetElapsedTime Method
IPluginHost Interface See Also フィードバックの送信
接続している放送の経過時間を取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
TimeSpan GetElapsedTime()
Visual Basic
Function GetElapsedTime As TimeSpan
Visual C++
TimeSpan GetElapsedTime()

Return Value

経過時間を表すTimeSpan

See Also

IPluginHost Interface


GetHeartBeat Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetHeartBeat Method
IPluginHost Interface See Also フィードバックの送信
現在保持しているHeartBeat情報を取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
NicoLiveHeartBeat GetHeartBeat()
Visual Basic
Function GetHeartBeat As NicoLiveHeartBeat
Visual C++
NicoLiveHeartBeat^ GetHeartBeat()

Return Value

HeartBeatデータ

See Also

IPluginHost Interface


GetLiveInfo Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetLiveInfo Method
IPluginHost Interface See Also フィードバックの送信
接続中放送の放送情報を取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
NicoLiveInfo GetLiveInfo()
Visual Basic
Function GetLiveInfo As NicoLiveInfo
Visual C++
NicoLiveInfo^ GetLiveInfo()

Return Value

放送情報

放送ページをスクレイピングして得た各種データとコミュニティページをスクレイピングして得た各種データを格納したクラス

See Also

IPluginHost Interface


GetOriginalNGWordInPlugin Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetOriginalNGWordInPlugin Method
IPluginHost Interface See Also フィードバックの送信
NG設定リストを取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
ConfigureOriginalNGWordInPlugin GetOriginalNGWordInPlugin()
Visual Basic
Function GetOriginalNGWordInPlugin As ConfigureOriginalNGWordInPlugin
Visual C++
ConfigureOriginalNGWordInPlugin^ GetOriginalNGWordInPlugin()

Return Value

NG設定リスト

See Also

IPluginHost Interface


GetPlayerStatus Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetPlayerStatus Method
IPluginHost Interface See Also フィードバックの送信
接続中放送のPlayerStatusを取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
NicoLivePlayerStatus GetPlayerStatus()
Visual Basic
Function GetPlayerStatus As NicoLivePlayerStatus
Visual C++
NicoLivePlayerStatus^ GetPlayerStatus()

Return Value

PlayerStatusデータ

See Also

IPluginHost Interface


GetPublishStatus Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetPublishStatus Method
IPluginHost Interface See Also フィードバックの送信
接続中放送のPublishStatusを取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
NicoLivePublishStatus GetPublishStatus()
Visual Basic
Function GetPublishStatus As NicoLivePublishStatus
Visual C++
NicoLivePublishStatus^ GetPublishStatus()

Return Value

PublishStatusデータ

See Also

IPluginHost Interface


GetSelectedCommentData Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetSelectedCommentData Method
IPluginHost Interface See Also フィードバックの送信
現在選択中のコメントデータを取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
LiveCommentData GetSelectedCommentData()
Visual Basic
Function GetSelectedCommentData As LiveCommentData
Visual C++
LiveCommentData^ GetSelectedCommentData()

Return Value

コメントデータ

See Also

IPluginHost Interface


GetUserSettingInPlugin Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetUserSettingInPlugin Method
IPluginHost Interface See Also フィードバックの送信
ユーザー設定リストを取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
UserSettingInPlugin GetUserSettingInPlugin()
Visual Basic
Function GetUserSettingInPlugin As UserSettingInPlugin
Visual C++
UserSettingInPlugin^ GetUserSettingInPlugin()

Return Value

ユーザー設定リスト

See Also

IPluginHost Interface


GetVersionInfo Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..GetVersionInfo Method
IPluginHost Interface See Also フィードバックの送信
NiconamaCommentViewerのバージョン情報を取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
VersionInfo GetVersionInfo()
Visual Basic
Function GetVersionInfo As VersionInfo
Visual C++
VersionInfo^ GetVersionInfo()

Return Value

バージョン情報

See Also

IPluginHost Interface


OpenCommentLog Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..OpenCommentLog Method
IPluginHost Interface See Also フィードバックの送信
コメントログファイルを開く

メインウィンドウの「ファイル→開く」を実行し、openFileDialogが開かれる

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void OpenCommentLog()
Visual Basic
Sub OpenCommentLog
Visual C++
void OpenCommentLog()

See Also

IPluginHost Interface


ReadAloudInPlugin Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..ReadAloudInPlugin Method
IPluginHost Interface See Also フィードバックの送信
オプションで設定されている読み上げツールで指定した文字列を読み上げる

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void ReadAloudInPlugin(
    string msg
)
Visual Basic
Sub ReadAloudInPlugin ( _
    msg As String _
)
Visual C++
void ReadAloudInPlugin(
    String^ msg
)

Parameters

msg
Type: System..::..String
読み上げ対象文字列

See Also

IPluginHost Interface


SendComment Method

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendComment Method
IPluginHost Interface See Also フィードバックの送信

Overload List

 | Name | Description
Public method | SendComment(String) | メインウィンドウで選択されているパラメータを使用して通常コメントを送信する
Public method | SendComment(String, String) | コマンド文字列を指定して通常コメントを送信する
Public method | SendComment(Boolean, String, String, String, String) | パラメータを指定して通常コメントを送信する

See Also

IPluginHost Interface
IPluginHost Members


SendComment Method (String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendComment Method (String)
IPluginHost Interface See Also フィードバックの送信
メインウィンドウで選択されているパラメータを使用して通常コメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendComment(
    string comment
)
Visual Basic
Function SendComment ( _
    comment As String _
) As Boolean
Visual C++
bool SendComment(
    String^ comment
)

Parameters

comment
Type: System..::..String
コメント文字列

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendComment Overload


SendComment Method (String, String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendComment Method (String, String)
IPluginHost Interface See Also フィードバックの送信
コマンド文字列を指定して通常コメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendComment(
    string command,
    string comment
)
Visual Basic
Function SendComment ( _
    command As String, _
    comment As String _
) As Boolean
Visual C++
bool SendComment(
    String^ command,
    String^ comment
)

Parameters

command
Type: System..::..String
コマンド文字列
comment
Type: System..::..String
コメント文字列

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendComment Overload


SendComment Method (Boolean, String, String, String, String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendComment Method (Boolean, String, String, String, String)
IPluginHost Interface See Also フィードバックの送信
パラメータを指定して通常コメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendComment(
    bool anonymity,
    string location,
    string size,
    string color,
    string comment
)
Visual Basic
Function SendComment ( _
    anonymity As Boolean, _
    location As String, _
    size As String, _
    color As String, _
    comment As String _
) As Boolean
Visual C++
bool SendComment(
    bool anonymity,
    String^ location,
    String^ size,
    String^ color,
    String^ comment
)

Parameters

anonymity
Type: System..::..Boolean
匿名かどうか。匿名ならtrue
location
Type: System..::..String
コメント表示位置
size
Type: System..::..String
文字の大きさ
color
Type: System..::..String
文字色
comment
Type: System..::..String
コメント文字列

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendComment Overload


SendOwnerComment Method

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendOwnerComment Method
IPluginHost Interface See Also フィードバックの送信

Overload List

 | Name | Description
Public method | SendOwnerComment(String) | メインウィンドウで選択されているパラメータを使用して運営コメントを送信する
Public method | SendOwnerComment(String, String, String) | コマンド文字列を指定して運営コメントを送信する
Public method | SendOwnerComment(Boolean, String, String, String, String, String, String) | パラメータを指定して運営コメントを送信する

See Also

IPluginHost Interface
IPluginHost Members


SendOwnerComment Method (String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendOwnerComment Method (String)
IPluginHost Interface See Also フィードバックの送信
メインウィンドウで選択されているパラメータを使用して運営コメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendOwnerComment(
    string comment
)
Visual Basic
Function SendOwnerComment ( _
    comment As String _
) As Boolean
Visual C++
bool SendOwnerComment(
    String^ comment
)

Parameters

comment
Type: System..::..String
コメント文字列

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendOwnerComment Overload


SendOwnerComment Method (String, String, String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendOwnerComment Method (String, String, String)
IPluginHost Interface See Also フィードバックの送信
コマンド文字列を指定して運営コメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendOwnerComment(
    string command,
    string comment,
    string name
)
Visual Basic
Function SendOwnerComment ( _
    command As String, _
    comment As String, _
    name As String _
) As Boolean
Visual C++
bool SendOwnerComment(
    String^ command,
    String^ comment,
    String^ name
)

Parameters

command
Type: System..::..String
コマンド文字列
comment
Type: System..::..String
コメント文字列
name
Type: System..::..String
投稿者名

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendOwnerComment Overload


SendOwnerComment Method (Boolean, String, String, String, String, String, String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendOwnerComment Method (Boolean, String, String, String, String, String, String)
IPluginHost Interface See Also フィードバックの送信
パラメータを指定して運営コメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendOwnerComment(
    bool anonymity,
    string location,
    string size,
    string color,
    string comment,
    string name,
    string sound
)
Visual Basic
Function SendOwnerComment ( _
    anonymity As Boolean, _
    location As String, _
    size As String, _
    color As String, _
    comment As String, _
    name As String, _
    sound As String _
) As Boolean
Visual C++
bool SendOwnerComment(
    bool anonymity,
    String^ location,
    String^ size,
    String^ color,
    String^ comment,
    String^ name,
    String^ sound
)

Parameters

anonymity
Type: System..::..Boolean
匿名かどうか。匿名ならtrue
location
Type: System..::..String
コメント表示位置
size
Type: System..::..String
文字の大きさ
color
Type: System..::..String
文字色
comment
Type: System..::..String
コメント文字列
name
Type: System..::..String
投稿者表示名
sound
Type: System..::..String
効果音

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendOwnerComment Overload


SendPresscastComment Method

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendPresscastComment Method
IPluginHost Interface See Also フィードバックの送信

Overload List

 | Name | Description
Public method | SendPresscastComment(String) | メインウィンドウで選択されているパラメータを使用してBSPコメントを送信する
Public method | SendPresscastComment(String, String, String) | パラメータを指定してBSPコメントを送信する

See Also

IPluginHost Interface
IPluginHost Members


SendPresscastComment Method (String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendPresscastComment Method (String)
IPluginHost Interface See Also フィードバックの送信
メインウィンドウで選択されているパラメータを使用してBSPコメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendPresscastComment(
    string comment
)
Visual Basic
Function SendPresscastComment ( _
    comment As String _
) As Boolean
Visual C++
bool SendPresscastComment(
    String^ comment
)

Parameters

comment
Type: System..::..String
コメント文字列

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendPresscastComment Overload


SendPresscastComment Method (String, String, String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SendPresscastComment Method (String, String, String)
IPluginHost Interface See Also フィードバックの送信
パラメータを指定してBSPコメントを送信する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool SendPresscastComment(
    string color,
    string comment,
    string name
)
Visual Basic
Function SendPresscastComment ( _
    color As String, _
    comment As String, _
    name As String _
) As Boolean
Visual C++
bool SendPresscastComment(
    String^ color,
    String^ comment,
    String^ name
)

Parameters

color
Type: System..::..String
文字色
comment
Type: System..::..String
コメント文字列
name
Type: System..::..String
投稿者表示名

Return Value

コメントの送信が成功したかどうか

See Also

IPluginHost Interface
SendPresscastComment Overload


SetRightclickMenuItemsInCommentDGV Method

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SetRightclickMenuItemsInCommentDGV Method
IPluginHost Interface See Also フィードバックの送信
データグリッドビューの右クリックメニューに項目を追加する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void SetRightclickMenuItemsInCommentDGV(
    IPlugin plugin,
    ToolStripMenuItem[] items
)
Visual Basic
Sub SetRightclickMenuItemsInCommentDGV ( _
    plugin As IPlugin, _
    items As ToolStripMenuItem() _
)
Visual C++
void SetRightclickMenuItemsInCommentDGV(
    IPlugin^ plugin,
    array<ToolStripMenuItem^>^ items
)

Parameters

plugin
Type: Plugin..::..IPlugin
メソッドを呼び出すプラグイン
items
Type: array< System.Windows.Forms..::..ToolStripMenuItem >[]()[][]
右クリックに追加する項目リスト

See Also

IPluginHost Interface


ShowMessageToStatusLabel Method

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..ShowMessageToStatusLabel Method
IPluginHost Interface See Also フィードバックの送信

Overload List

 | Name | Description
Public method | ShowMessageToStatusLabel(IPlugin, String) | メインウィンドウのステータスバーにメッセージを表示する
Public method | ShowMessageToStatusLabel(IPlugin, String, Color) | メインウィンドウのステータスバーにメッセージを表示する

See Also

IPluginHost Interface
IPluginHost Members


ShowMessageToStatusLabel Method (IPlugin, String)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..ShowMessageToStatusLabel Method (IPlugin, String)
IPluginHost Interface See Also フィードバックの送信
メインウィンドウのステータスバーにメッセージを表示する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void ShowMessageToStatusLabel(
    IPlugin plugin,
    string msg
)
Visual Basic
Sub ShowMessageToStatusLabel ( _
    plugin As IPlugin, _
    msg As String _
)
Visual C++
void ShowMessageToStatusLabel(
    IPlugin^ plugin,
    String^ msg
)

Parameters

plugin
Type: Plugin..::..IPlugin
メソッドを呼び出すプラグイン
msg
Type: System..::..String
表示するメッセージ

See Also

IPluginHost Interface
ShowMessageToStatusLabel Overload


ShowMessageToStatusLabel Method (IPlugin, String, Color)

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..ShowMessageToStatusLabel Method (IPlugin, String, Color)
IPluginHost Interface See Also フィードバックの送信
メインウィンドウのステータスバーにメッセージを表示する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
void ShowMessageToStatusLabel(
    IPlugin plugin,
    string msg,
    Color foreColor
)
Visual Basic
Sub ShowMessageToStatusLabel ( _
    plugin As IPlugin, _
    msg As String, _
    foreColor As Color _
)
Visual C++
void ShowMessageToStatusLabel(
    IPlugin^ plugin,
    String^ msg,
    Color foreColor
)

Parameters

plugin
Type: Plugin..::..IPlugin
メソッドを呼び出すプラグイン
msg
Type: System..::..String
表示するメッセージ
foreColor
Type: System.Drawing..::..Color
メッセージ表示色

See Also

IPluginHost Interface
ShowMessageToStatusLabel Overload


IPluginHost Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost Properties
IPluginHost Interface See Also フィードバックの送信

The IPluginHost type exposes the following members.

Properties

 | Name | Description
Public property | DirectoryPathAppSetting | アプリケーション設定保存フォルダの場所を取得する
Public property | DirectoryPathCommentLogFile | コメントログファイル保存フォルダの場所を取得する
Public property | DirectoryPathSettingFile | 設定ファイル保存フォルダの場所を取得する
Public property | IsConnected | コメントサーバーに接続しているかどうか
Public property | MainForm | ホストのメインフォーム

See Also

IPluginHost Interface


DirectoryPathAppSetting Property

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..DirectoryPathAppSetting Property
IPluginHost Interface See Also フィードバックの送信
アプリケーション設定保存フォルダの場所を取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
string DirectoryPathAppSetting { get; }
Visual Basic
ReadOnly Property DirectoryPathAppSetting As String
    Get
Visual C++
property String^ DirectoryPathAppSetting {
    String^ get ();
}

See Also

IPluginHost Interface


DirectoryPathCommentLogFile Property

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..DirectoryPathCommentLogFile Property
IPluginHost Interface See Also フィードバックの送信
コメントログファイル保存フォルダの場所を取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
string DirectoryPathCommentLogFile { get; }
Visual Basic
ReadOnly Property DirectoryPathCommentLogFile As String
    Get
Visual C++
property String^ DirectoryPathCommentLogFile {
    String^ get ();
}

See Also

IPluginHost Interface


DirectoryPathSettingFile Property

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..DirectoryPathSettingFile Property
IPluginHost Interface See Also フィードバックの送信
設定ファイル保存フォルダの場所を取得する

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
string DirectoryPathSettingFile { get; }
Visual Basic
ReadOnly Property DirectoryPathSettingFile As String
    Get
Visual C++
property String^ DirectoryPathSettingFile {
    String^ get ();
}

See Also

IPluginHost Interface


IsConnected Property

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..IsConnected Property
IPluginHost Interface See Also フィードバックの送信
コメントサーバーに接続しているかどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
bool IsConnected { get; }
Visual Basic
ReadOnly Property IsConnected As Boolean
    Get
Visual C++
property bool IsConnected {
    bool get ();
}

See Also

IPluginHost Interface


MainForm Property

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..MainForm Property
IPluginHost Interface See Also フィードバックの送信
ホストのメインフォーム

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
Form MainForm { get; }
Visual Basic
ReadOnly Property MainForm As Form
    Get
Visual C++
property Form^ MainForm {
    Form^ get ();
}

See Also

IPluginHost Interface


IPluginHost Events

[image] [image]

NiconamaCommentViwer Plug-in Documents
IPluginHost Events
IPluginHost Interface See Also フィードバックの送信

The IPluginHost type exposes the following members.

Events

 | Name | Description
Public event | BroadcastConnected | 放送接続直後に発生するイベント
Public event | BroadcastDisConnected | 放送終了直後に発生するイベント
Public event | CommentLogOpened | コメントログファイルオープン時に発生するイベント
Public event | HeartBeatUpdated | HeartBeat取得時に発生するイベント
Public event | ReceivedComment | コメント受信時に発生するイベント
Public event | SettingDirectoryChanged | 設定ファイル保存フォルダ変更時に発生するイベント
Public event | WaybackCommentReceived | 過去コメント1000件受信時に発生するイベント 最小コメ番の書き込み時間を基準に1000件遡るため、既得コメントと重複したコメントが含まれている可能性もある

See Also

IPluginHost Interface


BroadcastConnected Event

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..BroadcastConnected Event
IPluginHost Interface See Also フィードバックの送信
放送接続直後に発生するイベント

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
event BroadcastConnectedEventHandler BroadcastConnected
Visual Basic
Event BroadcastConnected As BroadcastConnectedEventHandler
Visual C++
 event BroadcastConnectedEventHandler^ BroadcastConnected {
    void add (BroadcastConnectedEventHandler^ value);
    void remove (BroadcastConnectedEventHandler^ value);
}

Remarks

発生するタイミングはコメントサーバーへ接続後、放送ページのスクレイピングが完了した直後です。

See Also

IPluginHost Interface


BroadcastDisConnected Event

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..BroadcastDisConnected Event
IPluginHost Interface See Also フィードバックの送信
放送終了直後に発生するイベント

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
event BroadcastDisConnectedEventHandler BroadcastDisConnected
Visual Basic
Event BroadcastDisConnected As BroadcastDisConnectedEventHandler
Visual C++
 event BroadcastDisConnectedEventHandler^ BroadcastDisConnected {
    void add (BroadcastDisConnectedEventHandler^ value);
    void remove (BroadcastDisConnectedEventHandler^ value);
}

Remarks

発生するタイミングは運営者権限で送信された"/disconnect"を受信したときです。

See Also

IPluginHost Interface


CommentLogOpened Event

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..CommentLogOpened Event
IPluginHost Interface See Also フィードバックの送信
コメントログファイルオープン時に発生するイベント

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
event CommentLogOpenedEventHandler CommentLogOpened
Visual Basic
Event CommentLogOpened As CommentLogOpenedEventHandler
Visual C++
 event CommentLogOpenedEventHandler^ CommentLogOpened {
    void add (CommentLogOpenedEventHandler^ value);
    void remove (CommentLogOpenedEventHandler^ value);
}

See Also

IPluginHost Interface


HeartBeatUpdated Event

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..HeartBeatUpdated Event
IPluginHost Interface See Also フィードバックの送信
HeartBeat取得時に発生するイベント

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
event HeartBeatUpdatedEventHandler HeartBeatUpdated
Visual Basic
Event HeartBeatUpdated As HeartBeatUpdatedEventHandler
Visual C++
 event HeartBeatUpdatedEventHandler^ HeartBeatUpdated {
    void add (HeartBeatUpdatedEventHandler^ value);
    void remove (HeartBeatUpdatedEventHandler^ value);
}

See Also

IPluginHost Interface


ReceivedComment Event

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..ReceivedComment Event
IPluginHost Interface See Also フィードバックの送信
コメント受信時に発生するイベント

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
event ReceivedCommentEventHandler ReceivedComment
Visual Basic
Event ReceivedComment As ReceivedCommentEventHandler
Visual C++
 event ReceivedCommentEventHandler^ ReceivedComment {
    void add (ReceivedCommentEventHandler^ value);
    void remove (ReceivedCommentEventHandler^ value);
}

See Also

IPluginHost Interface


SettingDirectoryChanged Event

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..SettingDirectoryChanged Event
IPluginHost Interface See Also フィードバックの送信
設定ファイル保存フォルダ変更時に発生するイベント

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
event SettingDirectoryChangedEventHandler SettingDirectoryChanged
Visual Basic
Event SettingDirectoryChanged As SettingDirectoryChangedEventHandler
Visual C++
 event SettingDirectoryChangedEventHandler^ SettingDirectoryChanged {
    void add (SettingDirectoryChangedEventHandler^ value);
    void remove (SettingDirectoryChangedEventHandler^ value);
}

See Also

IPluginHost Interface


WaybackCommentReceived Event

[image]

NiconamaCommentViwer Plug-in Documents
IPluginHost..::..WaybackCommentReceived Event
IPluginHost Interface See Also フィードバックの送信
過去コメント1000件受信時に発生するイベント

最小コメ番の書き込み時間を基準に1000件遡るため、既得コメントと重複したコメントが含まれている可能性もある

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
event WaybackCommentReceivedEventHandler WaybackCommentReceived
Visual Basic
Event WaybackCommentReceived As WaybackCommentReceivedEventHandler
Visual C++
 event WaybackCommentReceivedEventHandler^ WaybackCommentReceived {
    void add (WaybackCommentReceivedEventHandler^ value);
    void remove (WaybackCommentReceivedEventHandler^ value);
}

See Also

IPluginHost Interface


NGShareLevels Enumeration

[image]

NiconamaCommentViwer Plug-in Documents
NGShareLevels Enumeration
See Also フィードバックの送信

[Missing <summary> documentation for "T:Plugin.NGShareLevels"]

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public enum NGShareLevels
Visual Basic
Public Enumeration NGShareLevels
Visual C++
public enum class NGShareLevels

Members

Member name | Value | Description
Strong | 3 |
Moderate | 2 |
Weak | 1 |
None | 0 |

See Also

Plugin Namespace


ReadingOutApp Enumeration

[image]

NiconamaCommentViwer Plug-in Documents
ReadingOutApp Enumeration
See Also フィードバックの送信

[Missing <summary> documentation for "T:Plugin.ReadingOutApp"]

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public enum ReadingOutApp
Visual Basic
Public Enumeration ReadingOutApp
Visual C++
public enum class ReadingOutApp

Members

Member name | Value | Description
Bouyomityan | 1 |
SofTalk | 0 |

See Also

Plugin Namespace


ReceivedCommentEventArgs Class

[image]

NiconamaCommentViwer Plug-in Documents
ReceivedCommentEventArgs Class
Members See Also フィードバックの送信
ReceivedCommentイベントのデータ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class ReceivedCommentEventArgs : EventArgs
Visual Basic
Public Class ReceivedCommentEventArgs _
    Inherits EventArgs
Visual C++
public ref class ReceivedCommentEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Plugin..::..ReceivedCommentEventArgs

See Also

ReceivedCommentEventArgs Members


ReceivedCommentEventArgs Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
ReceivedCommentEventArgs Members
ReceivedCommentEventArgs Class Constructors Methods Properties See Also フィードバックの送信

The ReceivedCommentEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | ReceivedCommentEventArgs | Initializes a new instance of the ReceivedCommentEventArgs class

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | CommentDataList | コメントデータリスト

See Also

ReceivedCommentEventArgs Class


ReceivedCommentEventArgs Constructor

[image]

NiconamaCommentViwer Plug-in Documents
ReceivedCommentEventArgs Constructor
ReceivedCommentEventArgs Class See Also フィードバックの送信
Initializes a new instance of the ReceivedCommentEventArgs class

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public ReceivedCommentEventArgs(
    List<LiveCommentData> cdList
)
Visual Basic
Public Sub New ( _
    cdList As List(Of LiveCommentData) _
)
Visual C++
public:
ReceivedCommentEventArgs(
    List<LiveCommentData^>^ cdList
)

Parameters

cdList
Type: System.Collections.Generic..::..List <(Of <(<'LiveCommentData>)>)>

[Missing <param name="cdList"/> documentation for "M:Plugin.ReceivedCommentEventArgs.#ctor(System.Collections.Generic.List{NicoLibrary.NicoLiveData.LiveCommentData})"]

See Also

ReceivedCommentEventArgs Class


ReceivedCommentEventArgs Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
ReceivedCommentEventArgs Methods
ReceivedCommentEventArgs Class See Also フィードバックの送信

The ReceivedCommentEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

ReceivedCommentEventArgs Class


ReceivedCommentEventArgs Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
ReceivedCommentEventArgs Properties
ReceivedCommentEventArgs Class See Also フィードバックの送信

The ReceivedCommentEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CommentDataList | コメントデータリスト

See Also

ReceivedCommentEventArgs Class


CommentDataList Property

[image]

NiconamaCommentViwer Plug-in Documents
ReceivedCommentEventArgs..::..CommentDataList Property
ReceivedCommentEventArgs Class See Also フィードバックの送信
コメントデータリスト

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public List<LiveCommentData> CommentDataList { get; }
Visual Basic
Public ReadOnly Property CommentDataList As List(Of LiveCommentData)
    Get
Visual C++
public:
property List<LiveCommentData^>^ CommentDataList {
    List<LiveCommentData^>^ get ();
}

See Also

ReceivedCommentEventArgs Class


ReceivedCommentEventHandler Delegate

[image]

NiconamaCommentViwer Plug-in Documents
ReceivedCommentEventHandler Delegate
See Also フィードバックの送信
ReceivedCommentイベントのデリゲート

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public delegate void ReceivedCommentEventHandler(
    Object sender,
    ReceivedCommentEventArgs e
)
Visual Basic
Public Delegate Sub ReceivedCommentEventHandler ( _
    sender As Object, _
    e As ReceivedCommentEventArgs _
)
Visual C++
public delegate void ReceivedCommentEventHandler(
    Object^ sender,
    ReceivedCommentEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: Plugin..::..ReceivedCommentEventArgs

See Also

Plugin Namespace


SettingDirectoryChangedEventArgs Class

[image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventArgs Class
Members See Also フィードバックの送信
設定ファイル保存フォルダ変更イベントのデータ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class SettingDirectoryChangedEventArgs : EventArgs
Visual Basic
Public Class SettingDirectoryChangedEventArgs _
    Inherits EventArgs
Visual C++
public ref class SettingDirectoryChangedEventArgs : public EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
Plugin..::..SettingDirectoryChangedEventArgs

See Also

SettingDirectoryChangedEventArgs Members


SettingDirectoryChangedEventArgs Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventArgs Members
SettingDirectoryChangedEventArgs Class Constructors Methods Properties See Also フィードバックの送信

The SettingDirectoryChangedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | SettingDirectoryChangedEventArgs | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | NewSettingDirectory | 変更後の設定ファイル保存フォルダパス
Public property | OldSettingDirectory | 変更前の設定ファイル保存フォルダパス

See Also

SettingDirectoryChangedEventArgs Class


SettingDirectoryChangedEventArgs Constructor

[image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventArgs Constructor
SettingDirectoryChangedEventArgs Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public SettingDirectoryChangedEventArgs(
    string oldPath,
    string newPath
)
Visual Basic
Public Sub New ( _
    oldPath As String, _
    newPath As String _
)
Visual C++
public:
SettingDirectoryChangedEventArgs(
    String^ oldPath,
    String^ newPath
)

Parameters

oldPath
Type: System..::..String
変更前の設定ファイル保存フォルダパス
newPath
Type: System..::..String
変更後の設定ファイル保存フォルダパス

See Also

SettingDirectoryChangedEventArgs Class


SettingDirectoryChangedEventArgs Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventArgs Methods
SettingDirectoryChangedEventArgs Class See Also フィードバックの送信

The SettingDirectoryChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

SettingDirectoryChangedEventArgs Class


SettingDirectoryChangedEventArgs Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventArgs Properties
SettingDirectoryChangedEventArgs Class See Also フィードバックの送信

The SettingDirectoryChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | NewSettingDirectory | 変更後の設定ファイル保存フォルダパス
Public property | OldSettingDirectory | 変更前の設定ファイル保存フォルダパス

See Also

SettingDirectoryChangedEventArgs Class


NewSettingDirectory Property

[image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventArgs..::..NewSettingDirectory Property
SettingDirectoryChangedEventArgs Class See Also フィードバックの送信
変更後の設定ファイル保存フォルダパス

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string NewSettingDirectory { get; }
Visual Basic
Public ReadOnly Property NewSettingDirectory As String
    Get
Visual C++
public:
property String^ NewSettingDirectory {
    String^ get ();
}

See Also

SettingDirectoryChangedEventArgs Class


OldSettingDirectory Property

[image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventArgs..::..OldSettingDirectory Property
SettingDirectoryChangedEventArgs Class See Also フィードバックの送信
変更前の設定ファイル保存フォルダパス

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string OldSettingDirectory { get; }
Visual Basic
Public ReadOnly Property OldSettingDirectory As String
    Get
Visual C++
public:
property String^ OldSettingDirectory {
    String^ get ();
}

See Also

SettingDirectoryChangedEventArgs Class


SettingDirectoryChangedEventHandler Delegate

[image]

NiconamaCommentViwer Plug-in Documents
SettingDirectoryChangedEventHandler Delegate
See Also フィードバックの送信
設定ファイル保存フォルダ変更イベントのデリゲート

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public delegate void SettingDirectoryChangedEventHandler(
    Object sender,
    SettingDirectoryChangedEventArgs e
)
Visual Basic
Public Delegate Sub SettingDirectoryChangedEventHandler ( _
    sender As Object, _
    e As SettingDirectoryChangedEventArgs _
)
Visual C++
public delegate void SettingDirectoryChangedEventHandler(
    Object^ sender,
    SettingDirectoryChangedEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: Plugin..::..SettingDirectoryChangedEventArgs

See Also

Plugin Namespace


UserSettingInPlugin Class

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin Class
Members See Also フィードバックの送信
ユーザー設定

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class UserSettingInPlugin
Visual Basic
Public Class UserSettingInPlugin
Visual C++
public ref class UserSettingInPlugin

Inheritance Hierarchy

System..::..Object
Plugin..::..UserSettingInPlugin

See Also

UserSettingInPlugin Members


UserSettingInPlugin Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin Members
UserSettingInPlugin Class Constructors Methods Properties See Also フィードバックの送信

The UserSettingInPlugin type exposes the following members.

Constructors

 | Name | Description
Public method | UserSettingInPlugin()()()() | コンストラクタ
Public method | UserSettingInPlugin(List<(Of <<'(UserSettingInPlugin..::..UserData>)>>)) |

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | UserDataList | ユーザー設定リスト

See Also

UserSettingInPlugin Class


UserSettingInPlugin Constructor

[image] [image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin Constructor
UserSettingInPlugin Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | UserSettingInPlugin()()()() | コンストラクタ
Public method | UserSettingInPlugin(List<(Of <<'(UserSettingInPlugin..::..UserData>)>>)) | Initializes a new instance of the UserSettingInPlugin class

See Also

UserSettingInPlugin Class
UserSettingInPlugin Members


UserSettingInPlugin Constructor

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin Constructor
UserSettingInPlugin Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public UserSettingInPlugin()
Visual Basic
Public Sub New
Visual C++
public:
UserSettingInPlugin()

See Also

UserSettingInPlugin Class
UserSettingInPlugin Overload


UserSettingInPlugin Constructor (List(UserSettingInPlugin.UserData))

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin Constructor (List<(Of <(<'UserSettingInPlugin..::..UserData>)>)>)
UserSettingInPlugin Class See Also フィードバックの送信
Initializes a new instance of the UserSettingInPlugin class

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public UserSettingInPlugin(
    List<UserSettingInPlugin..::..UserData> userDataList
)
Visual Basic
Public Sub New ( _
    userDataList As List(Of UserSettingInPlugin..::..UserData) _
)
Visual C++
public:
UserSettingInPlugin(
    List<UserSettingInPlugin..::..UserData^>^ userDataList
)

Parameters

userDataList
Type: System.Collections.Generic..::..List <(Of <(<' UserSettingInPlugin..::..UserData >)>)>

[Missing <param name="userDataList"/> documentation for "M:Plugin.UserSettingInPlugin.#ctor(System.Collections.Generic.List{Plugin.UserSettingInPlugin.UserData})"]

See Also

UserSettingInPlugin Class
UserSettingInPlugin Overload


UserSettingInPlugin Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin Methods
UserSettingInPlugin Class See Also フィードバックの送信

The UserSettingInPlugin type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

UserSettingInPlugin Class


UserSettingInPlugin Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin Properties
UserSettingInPlugin Class See Also フィードバックの送信

The UserSettingInPlugin type exposes the following members.

Properties

 | Name | Description
Public property | UserDataList | ユーザー設定リスト

See Also

UserSettingInPlugin Class


UserDataList Property

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserDataList Property
UserSettingInPlugin Class See Also フィードバックの送信
ユーザー設定リスト

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public List<UserSettingInPlugin..::..UserData> UserDataList { get; }
Visual Basic
Public ReadOnly Property UserDataList As List(Of UserSettingInPlugin..::..UserData)
    Get
Visual C++
public:
property List<UserSettingInPlugin..::..UserData^>^ UserDataList {
    List<UserSettingInPlugin..::..UserData^>^ get ();
}

See Also

UserSettingInPlugin Class


UserSettingInPlugin.UserData Class

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData Class
UserSettingInPlugin Class Members See Also フィードバックの送信
ユーザー設定格納用構造体

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class UserData
Visual Basic
Public Class UserData
Visual C++
public ref class UserData

Inheritance Hierarchy

System..::..Object
Plugin..::..UserSettingInPlugin..::..UserData

See Also

UserSettingInPlugin..::..UserData Members


UserSettingInPlugin.UserData Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData Members
UserSettingInPlugin..::..UserData Class Constructors Methods Fields See Also フィードバックの送信

ユーザー設定

The UserSettingInPlugin..::..UserData type exposes the following members.

Constructors

 | Name | Description
Public method | UserSettingInPlugin..::..UserData | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Fields

 | Name | Description
Public field | BGColor | 背景色
Public field | CommunityNum | "ch"または"co"から始まる依存コミュニティ番号
Public field | IsReadOut | コメント読み上げ対象かどうか
Public field | NickName | ニックネーム
Public field | RegisterTime | 登録日時
Public field | UserId | ユーザーID

See Also

UserSettingInPlugin..::..UserData Class


UserSettingInPlugin.UserData Constructor

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData Constructor
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public UserData()
Visual Basic
Public Sub New
Visual C++
public:
UserData()

See Also

UserSettingInPlugin..::..UserData Class


UserSettingInPlugin.UserData Fields

[image] [image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData Fields
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信

The UserSettingInPlugin..::..UserData type exposes the following members.

Fields

 | Name | Description
Public field | BGColor | 背景色
Public field | CommunityNum | "ch"または"co"から始まる依存コミュニティ番号
Public field | IsReadOut | コメント読み上げ対象かどうか
Public field | NickName | ニックネーム
Public field | RegisterTime | 登録日時
Public field | UserId | ユーザーID

See Also

UserSettingInPlugin..::..UserData Class


BGColor Field

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData..::..BGColor Field
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信
背景色

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public Color BGColor
Visual Basic
Public BGColor As Color
Visual C++
public:
Color BGColor

See Also

UserSettingInPlugin..::..UserData Class


CommunityNum Field

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData..::..CommunityNum Field
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信
"ch"または"co"から始まる依存コミュニティ番号

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string CommunityNum
Visual Basic
Public CommunityNum As String
Visual C++
public:
String^ CommunityNum

See Also

UserSettingInPlugin..::..UserData Class


IsReadOut Field

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData..::..IsReadOut Field
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信
コメント読み上げ対象かどうか

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public bool IsReadOut
Visual Basic
Public IsReadOut As Boolean
Visual C++
public:
bool IsReadOut

See Also

UserSettingInPlugin..::..UserData Class


NickName Field

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData..::..NickName Field
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信
ニックネーム

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string NickName
Visual Basic
Public NickName As String
Visual C++
public:
String^ NickName

See Also

UserSettingInPlugin..::..UserData Class


RegisterTime Field

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData..::..RegisterTime Field
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信
登録日時

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string RegisterTime
Visual Basic
Public RegisterTime As String
Visual C++
public:
String^ RegisterTime

See Also

UserSettingInPlugin..::..UserData Class


UserId Field

[image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData..::..UserId Field
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信
ユーザーID

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string UserId
Visual Basic
Public UserId As String
Visual C++
public:
String^ UserId

See Also

UserSettingInPlugin..::..UserData Class


UserSettingInPlugin.UserData Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
UserSettingInPlugin..::..UserData Methods
UserSettingInPlugin..::..UserData Class See Also フィードバックの送信

The UserSettingInPlugin..::..UserData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

UserSettingInPlugin..::..UserData Class


VersionInfo Class

[image]

NiconamaCommentViwer Plug-in Documents
VersionInfo Class
Members See Also フィードバックの送信
バージョン情報

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public class VersionInfo
Visual Basic
Public Class VersionInfo
Visual C++
public ref class VersionInfo

Inheritance Hierarchy

System..::..Object
Plugin..::..VersionInfo

See Also

VersionInfo Members


VersionInfo Members

[image] [image]

NiconamaCommentViwer Plug-in Documents
VersionInfo Members
VersionInfo Class Constructors Methods Properties See Also フィードバックの送信

The VersionInfo type exposes the following members.

Constructors

 | Name | Description
Public method | VersionInfo()()()() | コンストラクタ
Public method | VersionInfo(String, String, String) | コンストラクタ

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

Properties

 | Name | Description
Public property | NCV_FileVersion | NiconamaCommentViewer 実行ファイル ファイルバージョン
Public property | NCVPlugin_FileVersion | NiconamaCommentViewer Plugin.dll ファイルバージョン
Public property | NicoLibrary_FileVersion | NicoLibrary.dll ファイルバージョン

See Also

VersionInfo Class


VersionInfo Constructor

[image] [image]

NiconamaCommentViwer Plug-in Documents
VersionInfo Constructor
VersionInfo Class See Also フィードバックの送信

Overload List

 | Name | Description
Public method | VersionInfo()()()() | コンストラクタ
Public method | VersionInfo(String, String, String) | コンストラクタ

See Also

VersionInfo Class
VersionInfo Members


VersionInfo Constructor

[image]

NiconamaCommentViwer Plug-in Documents
VersionInfo Constructor
VersionInfo Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public VersionInfo()
Visual Basic
Public Sub New
Visual C++
public:
VersionInfo()

See Also

VersionInfo Class
VersionInfo Overload


VersionInfo Constructor (String, String, String)

[image]

NiconamaCommentViwer Plug-in Documents
VersionInfo Constructor (String, String, String)
VersionInfo Class See Also フィードバックの送信
コンストラクタ

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public VersionInfo(
    string ncvFileVer,
    string nicoLibFileVer,
    string pluginFileVer
)
Visual Basic
Public Sub New ( _
    ncvFileVer As String, _
    nicoLibFileVer As String, _
    pluginFileVer As String _
)
Visual C++
public:
VersionInfo(
    String^ ncvFileVer,
    String^ nicoLibFileVer,
    String^ pluginFileVer
)

Parameters

ncvFileVer
Type: System..::..String
NiconamaCommentViewer.exe ファイルバージョン
nicoLibFileVer
Type: System..::..String
NicoLibrary.dll ファイルバージョン
pluginFileVer
Type: System..::..String
Plugin.dll ファイルバージョン

See Also

VersionInfo Class
VersionInfo Overload


VersionInfo Methods

[image] [image]

NiconamaCommentViwer Plug-in Documents
VersionInfo Methods
VersionInfo Class See Also フィードバックの送信

The VersionInfo type exposes the following members.

Methods

 | Name | Description
Public method | Equals | 指定した Object が、現在の Object と等しいかどうかを判断します。 (Inherited from Object.)
Protected method | Finalize | Object がガベージ コレクションにより収集される前に、その Object がリソースを解放し、その他のクリーンアップ操作を実行できるようにします。 (Inherited from Object.)
Public method | GetHashCode | 特定の型のハッシュ関数として機能します。 (Inherited from Object.)
Public method | GetType | 現在のインスタンスの Type を取得します。 (Inherited from Object.)
Protected method | MemberwiseClone | 現在の Object の簡易コピーを作成します。 (Inherited from Object.)
Public method | ToString | 現在の Object を表す String を返します。 (Inherited from Object.)

See Also

VersionInfo Class


VersionInfo Properties

[image] [image]

NiconamaCommentViwer Plug-in Documents
VersionInfo Properties
VersionInfo Class See Also フィードバックの送信

The VersionInfo type exposes the following members.

Properties

 | Name | Description
Public property | NCV_FileVersion | NiconamaCommentViewer 実行ファイル ファイルバージョン
Public property | NCVPlugin_FileVersion | NiconamaCommentViewer Plugin.dll ファイルバージョン
Public property | NicoLibrary_FileVersion | NicoLibrary.dll ファイルバージョン

See Also

VersionInfo Class


NCV_FileVersion Property

[image]

NiconamaCommentViwer Plug-in Documents
VersionInfo..::..NCV_FileVersion Property
VersionInfo Class See Also フィードバックの送信
NiconamaCommentViewer 実行ファイル ファイルバージョン

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string NCV_FileVersion { get; }
Visual Basic
Public ReadOnly Property NCV_FileVersion As String
    Get
Visual C++
public:
property String^ NCV_FileVersion {
    String^ get ();
}

See Also

VersionInfo Class


NCVPlugin_FileVersion Property

[image]

NiconamaCommentViwer Plug-in Documents
VersionInfo..::..NCVPlugin_FileVersion Property
VersionInfo Class See Also フィードバックの送信
NiconamaCommentViewer Plugin.dll ファイルバージョン

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string NCVPlugin_FileVersion { get; }
Visual Basic
Public ReadOnly Property NCVPlugin_FileVersion As String
    Get
Visual C++
public:
property String^ NCVPlugin_FileVersion {
    String^ get ();
}

See Also

VersionInfo Class


NicoLibrary_FileVersion Property

[image]

NiconamaCommentViwer Plug-in Documents
VersionInfo..::..NicoLibrary_FileVersion Property
VersionInfo Class See Also フィードバックの送信
NicoLibrary.dll ファイルバージョン

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public string NicoLibrary_FileVersion { get; }
Visual Basic
Public ReadOnly Property NicoLibrary_FileVersion As String
    Get
Visual C++
public:
property String^ NicoLibrary_FileVersion {
    String^ get ();
}

See Also

VersionInfo Class


WaybackCommentReceivedEventHandler Delegate

[image]

NiconamaCommentViwer Plug-in Documents
WaybackCommentReceivedEventHandler Delegate
See Also フィードバックの送信
WaybackCommentReceivedイベントのデリゲート

Namespace: Plugin
Assembly: Plugin (Plugin.dll 内) バージョン: 1.0.5284.14620

Syntax

C#
public delegate void WaybackCommentReceivedEventHandler(
    Object sender,
    ReceivedCommentEventArgs e
)
Visual Basic
Public Delegate Sub WaybackCommentReceivedEventHandler ( _
    sender As Object, _
    e As ReceivedCommentEventArgs _
)
Visual C++
public delegate void WaybackCommentReceivedEventHandler(
    Object^ sender,
    ReceivedCommentEventArgs^ e
)

Parameters

sender
Type: System..::..Object
e
Type: Plugin..::..ReceivedCommentEventArgs

See Also

Plugin Namespace